Bug 223062 - devel/php-composer runtime dependencies is missing mbstring
Summary: devel/php-composer runtime dependencies is missing mbstring
Status: Closed DUPLICATE of bug 223063
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-10-17 12:44 UTC by Felix Flor
Modified: 2017-10-18 08:00 UTC (History)
2 users (show)

See Also:
cyberbotx: maintainer-feedback+


Attachments
adding mbstring for USE_PHP (538 bytes, patch)
2017-10-17 12:44 UTC, Felix Flor
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Flor 2017-10-17 12:44:02 UTC
Created attachment 187233 [details]
adding mbstring for USE_PHP

Index: Makefile
===================================================================
--- Makefile    (revision 452274)
+++ Makefile    (working copy)
@@ -3,6 +3,7 @@
 
 PORTNAME=      composer
 DISTVERSION=   1.4.2
+PORTREVISION=  1
 CATEGORIES=    devel
 MASTER_SITES=  http://getcomposer.org/download/${DISTVERSION}/
 MAINTAINER=	cyberbotx@cyberbotx.com
 PKGNAMEPREFIX= php-
@@ -21,7 +22,7 @@
 NO_BUILD=      yes
 NO_WRKSUBDIR=  yes
 USES=          php
-USE_PHP=       intl openssl phar json ctype filter
+USE_PHP=       intl openssl phar json ctype filter mbstring
 
 PLIST_FILES=   bin/composer \
                bin/composer.phar
Comment 1 Naram Qashat 2017-10-18 04:12:13 UTC
(In reply to eqvvs from comment #0)

You included this in the update you provided in bug #223063. This bug is superfluous as a result and can be closed.
Comment 2 Torsten Zuehlsdorff freebsd_committer 2017-10-18 08:00:19 UTC

*** This bug has been marked as a duplicate of bug 223063 ***