Bug 223221 - x11-toolkits/qtermwidget: Update to 0.8.0
Summary: x11-toolkits/qtermwidget: Update to 0.8.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on: 223209
Blocks: 223223 223224
  Show dependency treegraph
 
Reported: 2017-10-24 14:15 UTC by Olivier Duchateau
Modified: 2017-10-27 15:47 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (jwb)


Attachments
Patch to update x11-toolkits/qtermwidget (5.20 KB, patch)
2017-10-24 14:15 UTC, Olivier Duchateau
no flags Details | Diff
set maintainer (4.48 KB, patch)
2017-10-26 08:44 UTC, Jesper Schmitz Mouridsen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau 2017-10-24 14:15:55 UTC
Created attachment 187434 [details]
Patch to update x11-toolkits/qtermwidget

- Update to 0.8.0
- Adjust dependencies
- Switch to USES=lxqt (bug #223209)
Comment 1 Jason W. Bacon freebsd_committer 2017-10-24 18:12:12 UTC
<<<ROOT@outpaddling.cs>>> /usr/ports/wip/qtermwidget080 1045 # make
===>  License GPLv2+ accepted by the user
===>   qtermwidget-0.8.0 depends on file: /usr/local/sbin/pkg - found
=> qtermwidget-0.8.0.tar.xz doesn't seem to exist in /usr/ports/distfiles/lxqt.
=> Attempting to fetch https://github.com/lxde/lxqt/releases/download/0.8.0/qtermwidget-0.8.0.tar.xz
fetch: https://github.com/lxde/lxqt/releases/download/0.8.0/qtermwidget-0.8.0.tar.xz: Not Found
=> Attempting to fetch http://downloads.lxqt.org/lxqt/0.8.0/qtermwidget-0.8.0.tar.xz
fetch: http://downloads.lxqt.org/lxqt/0.8.0/qtermwidget-0.8.0.tar.xz: Not Found
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/lxqt/qtermwidget-0.8.0.tar.xz
fetch: http://distcache.FreeBSD.org/ports-distfiles/lxqt/qtermwidget-0.8.0.tar.xz: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/lxqt and try again.
*** Error code 1

Stop.
make: stopped in /usr/ports/wip/qtermwidget080
Comment 2 Olivier Duchateau 2017-10-24 18:44:51 UTC
Are you apply the patch in bug #223209?
Comment 3 Jason W. Bacon freebsd_committer 2017-10-25 20:46:50 UTC
Applying 223209 helped, but this port also depends on bug 223210.  It's building now, but I'm still working on qterminal.
Comment 4 Jesper Schmitz Mouridsen freebsd_committer 2017-10-26 08:44:05 UTC
Created attachment 187492 [details]
set maintainer

No other changes to 
https://bugs.freebsd.org/bugzilla/attachment.cgi?id=187434
Comment 5 Jason W. Bacon freebsd_committer 2017-10-26 14:06:56 UTC
Comment on attachment 187492 [details]
set maintainer

Approved.
Comment 6 commit-hook freebsd_committer 2017-10-27 15:46:44 UTC
A commit references this bug:

Author: swills
Date: Fri Oct 27 15:45:46 UTC 2017
New revision: 453001
URL: https://svnweb.freebsd.org/changeset/ports/453001

Log:
  x11-toolkits/qtermwidget: Update to 0.8.0

  While here, set maintainer to maintainer of other lxqt related ports, Jesper
  Schmitz Mouridsen <jesper@schmitz.computer>

  PR:		223221
  Submitted by:	Olivier Duchateau <duchateau.olivier@gmail.com>
  Approved by:	Jason Bacon <bacon4000@gmail.com> (maintainer)

Changes:
  head/x11-toolkits/qtermwidget/Makefile
  head/x11-toolkits/qtermwidget/distinfo
  head/x11-toolkits/qtermwidget/files/patch-CMakeLists.txt
  head/x11-toolkits/qtermwidget/files/patch-cmake_create__pkgconfig__file.cmake
  head/x11-toolkits/qtermwidget/pkg-plist
Comment 7 Steve Wills freebsd_committer 2017-10-27 15:47:00 UTC
Committed, thanks!