Bug 223370 - [exp-run] graphics/glew update to 2.1.0
Summary: [exp-run] graphics/glew update to 2.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Niclas Zeising
URL:
Keywords:
: 214467 (view as bug list)
Depends on: 223426
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-01 16:28 UTC by Niclas Zeising
Modified: 2017-11-18 19:40 UTC (History)
3 users (show)

See Also:
zeising: exp-run?


Attachments
Update glew to 2.1.0 (6.60 KB, patch)
2017-11-01 16:28 UTC, Niclas Zeising
no flags Details | Diff
Portrevision bump of depending ports (24.70 KB, patch)
2017-11-01 16:29 UTC, Niclas Zeising
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Niclas Zeising freebsd_committer 2017-11-01 16:28:28 UTC
Created attachment 187653 [details]
Update glew to 2.1.0

graphics/glew update to 2.1.0. The patch is two parts, one that updates the port and one that bumps portrevision for depending ports, since the library version changes.
This needs an exp-run since it touches a few ports, among them libreoffice.
Comment 1 Niclas Zeising freebsd_committer 2017-11-01 16:29:05 UTC
Created attachment 187654 [details]
Portrevision bump of depending ports
Comment 2 Niclas Zeising freebsd_committer 2017-11-01 16:32:17 UTC
*** Bug 214467 has been marked as a duplicate of this bug. ***
Comment 3 Jan Beich freebsd_committer 2017-11-02 02:07:56 UTC
Note, bug 214467 comment 2 lists graphics/mitsuba but being currently marked BROKEN per bug 220719 it may end up as a false negative here.
Comment 4 Antoine Brodin freebsd_committer 2017-11-03 09:32:46 UTC
There is 1 new failure: multimedia/bino

Failure log:

http://package22.nyi.freebsd.org/data/110amd64-default-PR223370/2017-11-02_06h37m44s/logs/bino-1.4.2_11.log
Comment 5 Niclas Zeising freebsd_committer 2017-11-04 11:20:04 UTC
(In reply to Antoine Brodin from comment #4)
Hi!
Thanks for the run!
I noticed there's an upstream update available for multimedia/bino.  I'll try that one and see if I can get things going.
multimedia/bino hasn't been updated since 2013 (apart from bumps and stuff), and the last version update was probably not (looking at the logs) done by the maintainer.  I'm not sure if it is used.
If I'm unable to fix it, is it possible to get this approved anyway?
Comment 6 Niclas Zeising freebsd_committer 2017-11-04 14:22:37 UTC
I created a separate PR for the update to multimedia/bino, which makes it build with this update of graphics/glew.
Comment 7 commit-hook freebsd_committer 2017-11-18 19:32:58 UTC
A commit references this bug:

Author: zeising
Date: Sat Nov 18 19:32:31 UTC 2017
New revision: 454453
URL: https://svnweb.freebsd.org/changeset/ports/454453

Log:
  Update to 2.1.0

  Some hilights from release notes:
  * adds support for OpenGL 4.6
  * adds support for OSMesa and EGL
  * Removes  support for MX and removes related libraries

  Use upstream install target instead of our own do-install:
  Fix the pkgconfig script to actually tell something at least closer to the
  truth.
  Add missing GL dependencies.
  Library version bump.

  PR:		223370
  Submitted by:	zeising
  exp-run by:	antoine
  Approved by:	antoine

Changes:
  head/graphics/glew/Makefile
  head/graphics/glew/distinfo
  head/graphics/glew/files/patch-Makefile
  head/graphics/glew/files/patch-config__Makefile.freebsd
  head/graphics/glew/pkg-plist
Comment 8 commit-hook freebsd_committer 2017-11-18 19:33:00 UTC
A commit references this bug:

Author: zeising
Date: Sat Nov 18 19:32:45 UTC 2017
New revision: 454454
URL: https://svnweb.freebsd.org/changeset/ports/454454

Log:
  Bump portrevision to chase graphics/glew shard library version update.

  PR:		223370
  Submitted by:	zeising
  exp-run by:	antoine
  Approved by:	antoine

Changes:
  head/audio/clementine-player/Makefile
  head/cad/kicad/Makefile
  head/cad/kicad-devel/Makefile
  head/cad/meshlab/Makefile
  head/cad/openscad/Makefile
  head/cad/openvsp/Makefile
  head/cad/solvespace/Makefile
  head/devel/ChipmunkPhysics/Makefile
  head/devel/renpy/Makefile
  head/devel/rlvm/Makefile
  head/editors/libreoffice/Makefile
  head/emulators/dolphin-emu/Makefile
  head/emulators/mupen64plus-video-z64/Makefile
  head/emulators/openmsx/Makefile
  head/emulators/ppsspp/Makefile
  head/emulators/rpcs3/Makefile
  head/games/arx-libertatis/Makefile
  head/games/balazar/Makefile
  head/games/balazarbrothers/Makefile
  head/games/edge/Makefile
  head/games/endless-sky/Makefile
  head/games/flightgear/Makefile
  head/games/frogatto/Makefile
  head/games/gemrb/Makefile
  head/games/megaglest/Makefile
  head/games/openclonk/Makefile
  head/games/openspades/Makefile
  head/games/phlipple/Makefile
  head/games/py-fife/Makefile
  head/games/scorched3d/Makefile
  head/games/slade/Makefile
  head/games/slune/Makefile
  head/games/spring/Makefile
  head/games/stepmania-devel/Makefile
  head/games/supertux2/Makefile
  head/games/traingame/Makefile
  head/games/trenchbroom/Makefile
  head/games/trigger-rally/Makefile
  head/games/warzone2100/Makefile
  head/games/widelands/Makefile
  head/graphics/blender/Makefile
  head/graphics/cegui/Makefile
  head/graphics/colmap/Makefile
  head/graphics/enblend/Makefile
  head/graphics/gource/Makefile
  head/graphics/gstreamer-plugins-gl/Makefile
  head/graphics/hugin/Makefile
  head/graphics/libgltf/Makefile
  head/graphics/libprojectm/Makefile
  head/graphics/mesa-demos/Makefile
  head/graphics/mitsuba/Makefile
  head/graphics/opencolorio/Makefile
  head/graphics/opencsg/Makefile
  head/graphics/openimageio/Makefile
  head/graphics/opensubdiv/Makefile
  head/graphics/py-glewpy/Makefile
  head/graphics/py-soya3d/Makefile
  head/graphics/reallyslick/Makefile
  head/graphics/tulip/Makefile
  head/multimedia/bino/Makefile
  head/multimedia/kodi/Makefile
  head/net/mediastreamer/Makefile
  head/sysutils/logstalgia/Makefile
  head/www/wt/Makefile
  head/x11/slop/Makefile
Comment 9 Niclas Zeising freebsd_committer 2017-11-18 19:40:03 UTC
Committed!
Thanks for the help and the exp-run!