Bug 223371 - devel/p5-Paws: Update to 0.35
Summary: devel/p5-Paws: Update to 0.35
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jochen Neumeister
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2017-11-01 19:19 UTC by pprocacci
Modified: 2019-06-26 07:43 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kuriyama)


Attachments
Patch to upgrade to latest (71.73 KB, application/x-xz)
2017-11-01 19:19 UTC, pprocacci
no flags Details
Patch updates to 0.36 (71.07 KB, patch)
2017-11-06 19:56 UTC, pprocacci
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pprocacci 2017-11-01 19:19:50 UTC
Created attachment 187656 [details]
Patch to upgrade to latest

The current version of p5-Paws is quite old.  Please update to latest version.
The attached patch accomplishes this.  The attached patch also include fixes that aren't yet released.  Specifically:

https://github.com/pplu/aws-sdk-perl/issues/201
and
https://github.com/pplu/aws-sdk-perl/issues/201
Comment 2 pprocacci 2017-11-06 19:56:11 UTC
Created attachment 187808 [details]
Patch updates to 0.36

Update to 0.36
Comment 3 Jochen Neumeister freebsd_committer 2018-05-13 17:58:07 UTC
Maintainer timeout. Take this PR
Comment 4 Jochen Neumeister freebsd_committer 2018-05-14 16:06:55 UTC
(In reply to pprocacci from comment #2)

can you upload the diff again? 
I think, the attach has an error
Comment 5 pprocacci 2018-05-18 14:26:06 UTC
The patch applied perfectly for me.

My steps:

cd /usr/ports/devel

fetch -o p5-Paws-0.36.xz "https://bugs.freebsd.org/bugzilla/attachment.cgi?id=187808

unxz p5-Paws-0.36.xz

patch < ./p5-Paws.0.36.diff

make -C ./p5-Paws install clean
Comment 6 Johannes Jost Meixner freebsd_committer 2018-05-18 16:34:15 UTC
I can confirm it works and applies cleanly as an .xz archive.

That said, the preferred way to upload it would be as plain-text patch: Bugzilla has quite good integration with patches, showing what changes before downloading things.

Please consider that for your next contributions! :)
Comment 7 Jochen Neumeister freebsd_committer 2018-05-30 07:29:31 UTC
This patch doesn't work, see: http://joneumbox.org/data/11-1-AMD64-ports/2018-05-30_09h25m49s/logs/errors/p5-Paws-0.36.log

====> Compressing man pages (compress-man)
===========================================================================
====> Running Q/A tests (stage-qa)
Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'bin/xml2yaml.sh'
Warning: devel/p5-Getopt-Long is present in Perl CORE.  Check with `corelist Getopt::Long 0` and `corelist -a Getopt::Long` if the dependency is really needed or if it should be conditionally added depending on PERL_LEVEL
Warning: www/p5-HTTP-Tiny is present in Perl CORE.  Check with `corelist HTTP::Tiny 0` and `corelist -a HTTP::Tiny` if the dependency is really needed or if it should be conditionally added depending on PERL_LEVEL
Notice: You have some Perl modules as dependencies but you do not have devel/p5-Module-CoreList installed, the perlcore QA check gets better results when using it, especially with older Perl versions.
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/p5-Paws
=>> Error: stage-qa failures detected
=>> Cleaning up wrkdir
===>  Cleaning for p5-Paws-0.36
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2019-06-26 07:43:07 UTC
This should have been closed feedback timeout, with a comment clarifying that it was being closed due to not receiving an updated patch to address the failure outlined in comment 7.

Incidentally, please include logs as attachments not external URL references as they tend to go missing/stale over time ( this one is now 404).