Bug 223427 - DRM-NEXT does not work - ASRock J3355B-ITX - Celeron J3355 - Apollo Lake
Summary: DRM-NEXT does not work - ASRock J3355B-ITX - Celeron J3355 - Apollo Lake
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-04 15:41 UTC by vermaden
Modified: 2019-07-16 11:23 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vermaden 2017-11-04 15:41:31 UTC
Hi,

I have upgraded to FreeBSD 12-CURRENT from yesterday (2017/11/03) with GENERIC-NODEBUG config for the kernel.

% uname -a
FreeBSD bs.local 12.0-CURRENT FreeBSD 12.0-CURRENT #0: Sat Nov  4 00:38:39 CET 2017     root@bs.local:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG  amd64

Next I have upgraded all packages to be up to date with 'pkg upg' and then added 'drm-next-kmod' port.

Then I added 'kld_list="/boot/modules/i915kms.ko"' to /etc/rc.conf and rebooted.

Upon boot there are messages that firmware from 'gpu-firmware-kmod' package failed to load so there would be no power management.

After I started X11 then 'XFCE Destop' loaded and is usable, but any 3D application (glxgears/kodi) or movie player (mpv/vlc) ends with Segmentation Fault.

What other information do You need from me to dig the problem fuerther and fix that behavior so there would be working 3D, movies acceleration in hardware and proper power management?

Regards,
vermaden
Comment 1 vermaden 2017-11-22 11:12:21 UTC
What can I provide to start?
Comment 2 vermaden 2017-12-11 23:16:16 UTC
Also HDMI output does not work, VGA output works.
Comment 3 Niclas Zeising freebsd_committer 2019-07-10 08:42:25 UTC
Hi!
Is this still relevant with updated graphics driver and updated version of FreeBSD?
Comment 4 vermaden 2019-07-10 08:44:10 UTC
I did not upgraded to 13 recently.

Will have to check 11.3 with latest drm-kmod for another test ...
Comment 5 Niclas Zeising freebsd_committer 2019-07-10 10:38:28 UTC
(In reply to vermaden from comment #4)
> I did not upgraded to 13 recently.
> 
> Will have to check 11.3 with latest drm-kmod for another test ...

Hi!
Any chance you can test on 12.0 or 12-stable as well, especially since those use a newer version of drm-kmod than 11.3.
Thanks!
Comment 6 vermaden 2019-07-16 11:21:38 UTC
(In reply to Niclas Zeising from comment #5)

It turns out that I do not have that motherboard anymore :(

I would not be able to test it.

I think You can close the BUG as not solved.

Regards.
Comment 7 Niclas Zeising freebsd_committer 2019-07-16 11:23:39 UTC
Ok, closing this.
If you find that motherboard, or another, with a similar issue, please reopen this, or create a new PR.
Thanks!

I'm closing this as Unable to Reproduce, it feels like the most fitting category of those available in bugzilla.