Bug 223447 - print/indexinfo: segfault when some other ports are installed
Summary: print/indexinfo: segfault when some other ports are installed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Baptiste Daroussin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-05 15:01 UTC by Ting-Wei Lan
Modified: 2017-11-05 20:42 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bapt)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ting-Wei Lan 2017-11-05 15:01:45 UTC
I saw many 'indexinfo exited on signal 11' messages in dmesg that were caused by package upgrades:

pid 90666 (indexinfo), uid 0: exited on signal 11
pid 15254 (indexinfo), uid 0: exited on signal 11
pid 15347 (indexinfo), uid 0: exited on signal 11
pid 48021 (indexinfo), uid 0: exited on signal 11
pid 19681 (indexinfo), uid 0: exited on signal 11
pid 27803 (indexinfo), uid 0: exited on signal 11
pid 71035 (indexinfo), uid 0: exited on signal 11
pid 53440 (indexinfo), uid 0: exited on signal 11
pid 1024 (indexinfo), uid 0: exited on signal 11
pid 81133 (indexinfo), uid 0: exited on signal 11
pid 81253 (indexinfo), uid 0: exited on signal 11
pid 60237 (indexinfo), uid 0: exited on signal 11
pid 21268 (indexinfo), uid 0: exited on signal 11
pid 21372 (indexinfo), uid 0: exited on signal 11

After removing some files from /usr/local/info, I could run 'indexinfo /usr/local/info/' without seeing crashes. Here is the list of files I removed:

/usr/local/info/hte.info from editors/hte
/usr/local/info/octave.info from math/octave
/usr/local/info/liboctave.info from math/octave
/usr/local/info/mjpeg-howto.info from multimedia/mjpegtools
Comment 1 commit-hook freebsd_committer 2017-11-05 20:42:17 UTC
A commit references this bug:

Author: bapt
Date: Sun Nov  5 20:41:19 UTC 2017
New revision: 453561
URL: https://svnweb.freebsd.org/changeset/ports/453561

Log:
  Update to 0.3.1
  - Fix a segmentation faut with some manpages

  PR:		223447
  Reported by:	Ting-Wei Lan <lantw44@gmail.com>

Changes:
  head/print/indexinfo/Makefile
  head/print/indexinfo/distinfo