Bug 223465 - www/mod_auth_gssapi: Update to 1.6.0
Summary: www/mod_auth_gssapi: Update to 1.6.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Danilo G. Baio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-06 08:35 UTC by Christian Ullrich
Modified: 2017-11-12 21:38 UTC (History)
2 users (show)

See Also:
dbaio: maintainer-feedback+


Attachments
Patch (987 bytes, patch)
2017-11-06 08:35 UTC, Christian Ullrich
no flags Details | Diff
Patch (1.31 KB, patch)
2017-11-06 10:24 UTC, Christian Ullrich
chris: maintainer-approval+
Details | Diff
Patch (1.72 KB, patch)
2017-11-06 12:24 UTC, Christian Ullrich
chris: maintainer-approval+
Details | Diff
Build log (40.62 KB, text/plain)
2017-11-11 22:57 UTC, Christian Ullrich
no flags Details
Updated patch (2.29 KB, patch)
2017-11-12 13:10 UTC, Christian Ullrich
chris: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ullrich 2017-11-06 08:35:07 UTC
Created attachment 187787 [details]
Patch

This updates www/mod_auth_gssapi to version 1.6.0 released on 2017-11-05.
Comment 1 Christian Ullrich 2017-11-06 09:21:17 UTC
Not quite yet. 1.6.0 claims support for LibreSSL; I missed that at first. Updated patch will come once testing done.
Comment 2 Christian Ullrich 2017-11-06 10:24:50 UTC
Created attachment 187788 [details]
Patch

Updated patch; removes LibreSSL block.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2017-11-06 11:58:32 UTC
Please:

Confirm this change passes QA (portlint, poudriere in particular)

Declare maintainer approval on attachments for ports you main by setting maintainer-approval flag to +. 

Attachment -> Details -> maintainer-approval [+]
Comment 4 Christian Ullrich 2017-11-06 12:24:50 UTC
Created attachment 187793 [details]
Patch

Updated patch yet again, to satisfy portlint about the order of USES and USE_*, as silly as that may be.

Poudriere passes with DEFAULT_VERSIONS ssl=openssl, ssl=libressl, and ssl=libressl-devel, and the resulting module works correctly in Apache 2.4 with both openssl and libressl-devel.
Comment 6 Christian Ullrich 2017-11-11 22:57:33 UTC
Created attachment 187927 [details]
Build log

Hello,

I cannot reproduce this on 11.1-STABLE. In particular, the missing "s" is where it belongs in every declaration of yyparse() throughout parser.c .

The only thing I can think of is that byacc might have lost it through some bug of its own, and using bison instead avoided that.

Could you try again with the original patch, and if it keeps failing, check whether the "s" is actually present in parser.y and missing in parser.c ?
Comment 7 Danilo G. Baio freebsd_committer 2017-11-12 02:11:38 UTC
(In reply to Christian Ullrich from comment #6)

Sure, tests without bison:

10.3-RELEASE-p21 -> byacc - 1.9 20141006 ERROR
11.0-RELEASE-p12 -> byacc - 1.9 20160324 ERROR
12.0-CURRENT -> byacc - 1.9 20170430  OK

ERROR

/* compatibility with bison */
#ifdef YYPARSE_PARAM
/* compatibility with FreeBSD */
# ifdef YYPARSE_PARAM_TYPE
#  define YYPARSE_DECL() yyparse(YYPARSE_PARAM_TYPE YYPARSE_PARAM)
# else
#  define YYPARSE_DECL() yyparse(void *YYPARSE_PARAM)
# endif
#else
# define YYPARSE_DECL() yyparse(const char **keys, const char **vals, int *statu)
#endif


OK

/* compatibility with bison */
#ifdef YYPARSE_PARAM
/* compatibility with FreeBSD */
# ifdef YYPARSE_PARAM_TYPE
#  define YYPARSE_DECL() yyparse(YYPARSE_PARAM_TYPE YYPARSE_PARAM)
# else
#  define YYPARSE_DECL() yyparse(void *YYPARSE_PARAM)
# endif
#else
# define YYPARSE_DECL() yyparse(const char **keys, const char **vals, int *status)
#endif


http://poudriere.bs2.com.br/parser.c
http://poudriere.bs2.com.br/parser.y
Comment 8 Christian Ullrich 2017-11-12 13:10:08 UTC
Created attachment 187940 [details]
Updated patch

I do not have the faintest idea what is going on here ...

I tested all version of byacc that have been released with everything since 10.0, and in isolation, none of them exhibits the bug. The binaries from the poudriere jails, on the other hand, do:

- 10.4-RELEASE-p2  (-s http): Error
- 10.4-STABLE      (-s svn):  Error
- 11.0-RELEASE-p14 (-s http): Error
- 11.1-RELEASE-p3  (-s http): OK

11-STABLE is OK, as seen yesterday.

Rather than delve deeper into this thing, I came up with an, um, "creative" workaround; see new patch. With this patch, it works on all versions listed above.

If I may, I will leave it up to you whether to commit this, or add the bison dependency instead.
Comment 9 commit-hook freebsd_committer 2017-11-12 21:35:30 UTC
A commit references this bug:

Author: dbaio
Date: Sun Nov 12 21:34:26 UTC 2017
New revision: 454085
URL: https://svnweb.freebsd.org/changeset/ports/454085

Log:
  www/mod_auth_gssapi: Update to 1.6.0

  It was added support for LibreSSL upstream.

  While here, sort USES and add bison as build dependency
  because there is an issue when building with byacc < 20170201,
  more details in PR 223465.

  Changes:	https://github.com/modauthgssapi/mod_auth_gssapi/releases/tag/v1.6.0

  PR:		223465
  Submitted by:	Christian Ullrich <chris@chrullrich.net> (maintainer)

Changes:
  head/www/mod_auth_gssapi/Makefile
  head/www/mod_auth_gssapi/distinfo
Comment 10 commit-hook freebsd_committer 2017-11-12 21:37:33 UTC
A commit references this bug:

Author: dbaio
Date: Sun Nov 12 21:36:47 UTC 2017
New revision: 51195
URL: https://svnweb.freebsd.org/changeset/doc/51195

Log:
  Add Christian Ullrich to contributors

  Maintainer of www/mod_auth_gssapi and www/multiwatch.

  PR:		223465

Changes:
  head/en_US.ISO8859-1/articles/contributors/contrib.additional.xml
Comment 11 Danilo G. Baio freebsd_committer 2017-11-12 21:38:09 UTC
Committed with bison dependency, thanks!