Bug 223497 - x11-themes/gtk-xfce-engine missing gtk-3.0 support
Summary: x11-themes/gtk-xfce-engine missing gtk-3.0 support
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-xfce mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-07 18:33 UTC by J.R. Oldroyd
Modified: 2017-11-13 17:00 UTC (History)
2 users (show)

See Also:
madpilot: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J.R. Oldroyd 2017-11-07 18:33:41 UTC
Gtk-3.0 applications - e.g., firefox - now look like crap under Xfce using most of the default themes.  This is due to the fact that the x11-themes/gtk-xfce-engine is built without gtk-3.0 support.  Support for gtk-3.0 can be enabled by adding a CONFIGURE_ARG="--enable-gtk3" to the Makefile and then by updating the plist to add all the extra gtk-3.0/gtk.css files that are installed.
Comment 1 Guido Falsi freebsd_committer 2017-11-07 18:49:44 UTC
Thanks for the suggestion.

I'll have a look and do some tests.
Comment 2 Olivier Duchateau 2017-11-07 19:29:05 UTC
(In reply to Guido Falsi from comment #1)

No, it's bad idea. Gtk3 is not supported by the gtk-xfce-engine (it works fine for early version of Gtk < 3.8). There're lots of change since 3.18.

if you need a good Gtk3 theme, install gnome-theme-standard (and select Adwaita theme). It contains both Gtk2 and Gt3 themes (and it follows update of the GNOME team). You can also try the Greybird theme (there is an update on the BugZilla).

At the time there was a discussion about it [1]. Moreover gtk-xfce-engine is now deprecated by upstream (not any more maintained).

[1] https://mail.xfce.org/pipermail/xfce4-dev/2015-February/031062.html
Comment 3 J.R. Oldroyd 2017-11-08 20:55:53 UTC
Thanks for the pointer on needing x11-themes/gnome-themes-standard to get the Adwaita theme.  I already had x11-themes/adwaita-icon-theme and therefore thought I had this theme, but apparently the latter is just the icon set and not the Gtk themes.

Even though the file share/themes/Adwaita/gtk-3.0/gtk.css is empty (save for a comment saying the file is not used), installing this port does seem to fix a lot of the ugliness I was seeing with firefox and other gtk3 apps.

So, if gtk-xfce-engine is being deprecated, I guess adding the Gtk3 port compilation option is moot.
Comment 4 Guido Falsi freebsd_committer 2017-11-13 17:00:22 UTC
Closing this bug.

Thanks to Olivier for providing the information and links.