Bug 223515 - troff crashes with Signal 6 (core dumped)
Summary: troff crashes with Signal 6 (core dumped)
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: gnu (show other bugs)
Version: 11.1-STABLE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks: 223516
  Show dependency treegraph
 
Reported: 2017-11-08 10:13 UTC by Wolfram Schneider
Modified: 2017-11-20 18:29 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfram Schneider freebsd_committer 2017-11-08 10:13:35 UTC
I tried to find out how much time we need to render a manual page, and looked for the largest manpage. I found in the ports collection the salt(7) manpage from the saltstack (https://saltstack.com/)

When I run the man command I noticed that groff crashes with signal 6.

How to repeat:

$ fetch https://www.freebsd.org/~wosch/tmp/salt.7.gz
$ zcat salt.7.gz | groff >/dev/null; echo $?

<standard input>:860: warning: can't find character with input code 153
<standard input>:3504: warning [p 22, 5.8i]: can't break line
[....]
troff: Failed assertion at line 510, file `/usr/src/gnu/usr.bin/groff/src/roff/troff/../../../../../../contrib/groff/src/roff/troff/input.cpp'.
groff: troff: Signal 6 (core dumped)
grops:<standard input>:1960401:warning: no final `x stop' command
2


$ groff --version
GNU groff version 1.19.2
Comment 1 Ed Maste freebsd_committer 2017-11-20 15:09:53 UTC
Which FreeBSD version? The 'Version' field is set to CURRENT, but troff is not included in the base system in CURRENT.
Comment 2 Wolfram Schneider freebsd_committer 2017-11-20 15:41:43 UTC
(In reply to Ed Maste from comment #1)

FreeBSD 12.0-CURRENT from Nov 17 2017 (upgraded from FreeBSD 11.1-STABLE a week ago).

I see the problem also on FreeBSD 11.1-STABLE
Comment 3 Ed Maste freebsd_committer 2017-11-20 15:48:50 UTC
Recent 12-CURRENT does not provide /usr/bin/troff - perhaps you did not run make delete-old after the upgrade from 11?
Comment 4 Wolfram Schneider freebsd_committer 2017-11-20 18:29:42 UTC
(In reply to Ed Maste from comment #3)

You are right - I forgot to run 'make delete-old'. I assumed this is part of 'make installworld'. My bad, sorry.