Bug 223537 - [patch] devel/include-what-you-use update to 0.8
Summary: [patch] devel/include-what-you-use update to 0.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-11-08 14:12 UTC by Anton Yuzhaninov
Modified: 2017-12-24 14:20 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (koobs)


Attachments
Update to 0.8 (1.72 KB, patch)
2017-11-08 14:12 UTC, Anton Yuzhaninov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Yuzhaninov 2017-11-08 14:12:10 UTC
Created attachment 187860 [details]
Update to 0.8

Please update port devel/include-what-you-use to 0.8. Patch attached.

BROKEN variable was moved to fix portlint warning.

Tested with poudriere on i386/amd64 for supported releases.
Comment 1 Rene Ladan freebsd_committer 2017-12-24 11:54:56 UTC
Taking over, maintainer timeout
Comment 2 commit-hook freebsd_committer 2017-12-24 14:20:22 UTC
A commit references this bug:

Author: rene
Date: Sun Dec 24 14:20:07 UTC 2017
New revision: 457165
URL: https://svnweb.freebsd.org/changeset/ports/457165

Log:
  devel/include-what-you-use: update to version 0.8

  This version uses clang 4.0 instead of clang 3.9 to check files.
  While here, pet portlint.

  PR:		223537
  Submitted by:	Anton Yuzhaninov (citrin+pr@citrin.ru)
  Approved by:	maintainer timeout (koobs, 7 weeks)

Changes:
  head/devel/include-what-you-use/Makefile
  head/devel/include-what-you-use/distinfo
Comment 3 Rene Ladan freebsd_committer 2017-12-24 14:20:42 UTC
Committed, thanks!