Bug 223668 - www/qt5-webkit ES6 Proxy support incomplete
Summary: www/qt5-webkit ES6 Proxy support incomplete
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords: easy, patch-ready
Depends on:
Blocks:
 
Reported: 2017-11-14 15:59 UTC by Mikhail T.
Modified: 2017-11-14 19:32 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments
v1 (2.01 KB, patch)
2017-11-14 18:51 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail T. 2017-11-14 15:59:44 UTC
The current version of the toolkit advertises the support for ES6 proxying without being able to fully support it.

This causes failures on complex web-sites such as those of Slack.com, breaking both the net-im/diligent we already have in the tree and the net-im/py-scudcloud I'd like to add. See:

   https://github.com/raelgc/scudcloud/issues/594

The patch offered by the maintainer of the webkit fork we use helps solve the problem:

   https://github.com/raelgc/scudcloud/issues/594#issuecomment-342988247

The actual patch we need is in the comment right after the above, the rest of the author's change cleans up the tests we do not use.
Comment 1 Tobias C. Berner freebsd_committer 2017-11-14 18:51:31 UTC
Created attachment 187999 [details]
v1

Hi there

Could you confirm whether this is solves the problem for you? 


mfg Tobias
Comment 2 Mikhail T. 2017-11-14 19:12:22 UTC
Comment on attachment 187999 [details]
v1

> Could you confirm whether this is solves the problem for you?

Yes, it seems like a faithful replication of the patch I linked to. Thanks!
Comment 3 commit-hook freebsd_committer 2017-11-14 19:32:28 UTC
A commit references this bug:

Author: tcberner
Date: Tue Nov 14 19:31:22 UTC 2017
New revision: 454197
URL: https://svnweb.freebsd.org/changeset/ports/454197

Log:
  www/qt5-webkit add upstream patch to disable broken ES6 proxy support

  PR:		223668
  Submitted by:	Mikhail T.  <mi@ALDAN.algebra.com>

Changes:
  head/www/qt5-webkit/Makefile
  head/www/qt5-webkit/files/patch-git_5648446
Comment 4 Tobias C. Berner freebsd_committer 2017-11-14 19:32:48 UTC
Committed. Thanks.