Bug 223692 - security/acme-client fails to build as a user when libressl is not the default ssl library in poudriere
Summary: security/acme-client fails to build as a user when libressl is not the defaul...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Bernard Spil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-15 22:24 UTC by Guido Falsi
Modified: 2017-12-23 12:40 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (brnrd)


Attachments
Quick fix (422 bytes, patch)
2017-11-15 22:24 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2017-11-15 22:24:14 UTC
Created attachment 188032 [details]
Quick fix

In the latest poudriere version te default is to build ports as a user.

acme-client fails with the following error, when SSL_DEFAULT != libressl:

===>   Returning to build of acme-client-0.1.16_1
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for acme-client-0.1.16_1
chmod: ./bin/openssl: Operation not permitted
chmod: ./bin/nc: Operation not permitted
chmod: ./bin/ocspcheck: Operation not permitted
*** Error code 1

Stop.
make: stopped in /usr/ports/security/acme-client
=>> Cleaning up wrkdir


Attached patch avoids copying those files, avoiding the error.
Comment 1 Bernard Spil freebsd_committer 2017-12-23 10:57:27 UTC
Looks like something in poudriere changed that triggers this.
Testing now...
Comment 2 Guido Falsi freebsd_committer 2017-12-23 11:16:21 UTC
(In reply to Bernard Spil from comment #1)
> Looks like something in poudriere changed that triggers this.
> Testing now...

Yes, since version 3.2.0 poudriere has BUILD_AS_NON_ROOT tuned on by default [1]


[1] https://github.com/freebsd/poudriere/wiki/release_notes_32
Comment 3 commit-hook freebsd_committer 2017-12-23 12:39:05 UTC
A commit references this bug:

Author: brnrd
Date: Sat Dec 23 12:38:36 UTC 2017
New revision: 457047
URL: https://svnweb.freebsd.org/changeset/ports/457047

Log:
  security/acme-client: Unbreak build

  PR:		223692
  Reported by:	madpilot@
  MFH:		2017Q4

Changes:
  head/security/acme-client/Makefile