Bug 223721 - textproc/htmldoc: [PATCH] Update to 1.9.3
Summary: textproc/htmldoc: [PATCH] Update to 1.9.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-17 17:13 UTC by Zsolt Udvari
Modified: 2018-12-09 02:49 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (jose)


Attachments
Update (16.97 KB, patch)
2018-08-24 04:18 UTC, Nathan
no flags Details | Diff
Update (16.95 KB, patch)
2018-08-24 23:09 UTC, Nathan
no flags Details | Diff
Update; Fix SSL(GNUTLS) (16.92 KB, patch)
2018-08-25 01:53 UTC, Nathan
no flags Details | Diff
Patch rebased over 478107 (16.93 KB, text/plain)
2018-08-26 08:34 UTC, Xin LI
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zsolt Udvari 2017-11-17 17:13:23 UTC
The new version (1.9.1) is released.
The new homepage is http://michaelrsweet.github.io/htmldoc/ (and https://github.com/michaelrsweet/htmldoc/).
Comment 1 Nathan 2018-08-24 00:59:09 UTC
I've got a patch ready, doing QA on it currently
Comment 2 Nathan 2018-08-24 04:18:38 UTC
Created attachment 196490 [details]
Update

 textproc/htmldoc:
 
 * Update to 1.9.3
 * Rearranged Options
   -- Makes it easier to find them
 * Removed jpeg from USES
   -- Only needed if HTMLDOCGUI is enabled
   -- Added it to OPTION if enabled
 * Removed previous configure_args
   -- Builds fine, even with gnutls enabled
 * Used ${REINPLACE_CMD} if arch is arm64
   -- arm64 does't support png neon support
 
 Changelog: https://github.com/michaelrsweet/htmldoc/blob/master/CHANGES.md
Comment 3 Nathan 2018-08-24 04:20:29 UTC
(In reply to Nathan from comment #2)
Tested in 
poudriere(amd64) 11.2 10.4
poudriere(i386) 11.2
poudriere(armv6)
poudriere(arm64)

Above built fine, but not mips
Comment 4 Nathan 2018-08-24 04:28:21 UTC
Also tested on 12-current jail and built fine as well so i think it will also fix 228944
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-24 09:21:44 UTC
Add bugs claimed to be resolved by this bug at Nathans request.

@Nathan please confirm (explicitly, here) that this update fixes (confirmed to build with openssl 1.1 successfully in poudriere) bug 228944
Comment 6 Nathan 2018-08-24 11:10:37 UTC
It built fine for me. The only thing I’m unsure of is if the build is enabling ssl. Hoping to get others to test it. I DO know it’s building fine but would like confirmation if SSL is working or not as the following is in configure run:

configure: Using SSLFLAGS="", SSLLIBS=""
Comment 7 Nathan 2018-08-24 18:17:00 UTC
(In reply to Nathan from comment #6)
Update. I’m thinking ssl isn’t being used atm. Gonna be working on fixing the issue
Comment 8 Nathan 2018-08-24 23:09:36 UTC
Created attachment 196508 [details]
Update

Seems SSL is enabled if GNUTLS is installed, atleast the library. Need people with 12-current to test this. I tried testing in my 12-current jail but it fails building with python
Comment 9 Nathan 2018-08-25 01:31:41 UTC
(In reply to Nathan from comment #8)
Update, according to upstream, openssl is not supported:
https://github.com/michaelrsweet/htmldoc/issues/336#event-1808757060

Bug #228944 will not apply after this update
Comment 10 Nathan 2018-08-25 01:53:55 UTC
Created attachment 196513 [details]
Update; Fix SSL(GNUTLS)

Added pkgconfig, so gnutls will be found
Comment 11 Xin LI freebsd_committer 2018-08-26 08:34:23 UTC
Created attachment 196557 [details]
Patch rebased over 478107
Comment 12 Sean Bruno freebsd_committer 2018-11-29 17:20:02 UTC
(In reply to Xin LI from comment #11)
*sigh*

Sorry to ask this, but the Makefile seems to fail to patch.  I'd update it myself, but its a bit more complicated than I'm comfortable with.  Can you regenerate it?
Comment 13 Xin LI freebsd_committer 2018-11-29 17:57:44 UTC
(In reply to Sean Bruno from comment #12)
I thought the conflict might be caused by the s/openssl-devel/openssl111/g change, if you apply on that, will it allow you to apply the patch cleanly?

I can take a look later time tonight.
Comment 14 commit-hook freebsd_committer 2018-12-09 02:49:00 UTC
A commit references this bug:

Author: swills
Date: Sun Dec  9 02:48:32 UTC 2018
New revision: 487012
URL: https://svnweb.freebsd.org/changeset/ports/487012

Log:
  textproc/htmldoc: Update to 1.9.3

  PR:		223721
  Submitted by:	Nathan <ndowens@yahoo.com>
  Submitted by:	delphij
  Reported by:	Zsolt Udvari <uzsolt@uzsolt.hu>

Changes:
  head/textproc/htmldoc/Makefile
  head/textproc/htmldoc/distinfo
  head/textproc/htmldoc/files/
  head/textproc/htmldoc/pkg-descr
Comment 15 Steve Wills freebsd_committer 2018-12-09 02:49:32 UTC
Committed, forgot to mention the maintainer timeout in the commit, sorry. Thanks for the patch!