Bug 223764 - devel/py-qt5-core: py36-qt5-core-5.7.1 conflicts with py27-qt5-core-5.7.1: need to rename pyuic5?
Summary: devel/py-qt5-core: py36-qt5-core-5.7.1 conflicts with py27-qt5-core-5.7.1: ne...
Status: Closed DUPLICATE of bug 219641
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-20 10:38 UTC by Yuri Victorovich
Modified: 2018-10-27 12:19 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2017-11-20 10:38:59 UTC
> pkg-static: py36-qt5-core-5.7.1 conflicts with py27-qt5-core-5.7.1 (installs files into the same place).  Problematic file: /usr/local/bin/pyuic5
Comment 1 Rainer Hurling freebsd_committer 2017-12-15 10:43:10 UTC
As far as I can see, this doubles bug #219641
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-03-07 06:19:48 UTC
Should fixed with
https://svnweb.freebsd.org/ports?view=revision&revision=461841 (?).
Comment 3 Loïc Bartoletti freebsd_committer 2018-03-11 07:26:12 UTC
For me it's not yet fixed, using latest packages:

For QT5, having py36-qt5 still installed.

pkg install py27-qt5-xml:
Checking integrity... done (2 conflicting)
  - py27-qt5-xml-5.9.2_4 conflicts with py36-qt5-xml-5.9.2_4 on /usr/local/bin/pylupdate5
  - py27-qt5-core-5.9.2_4 conflicts with py36-qt5-core-5.9.2_4 on /usr/local/bin/pyuic5



For QT4, having py27-qt4 still installed.

pkg install py36-qt4-xml:
Checking integrity... done (2 conflicting)
  - py36-qt4-xml-4.12.1_1,1 conflicts with py27-qt4-xml-4.12.1_1,1 on /usr/local/bin/pylupdate4
  - py36-qt4-core-4.12.1_5,1 conflicts with py27-qt4-core-4.12.1_5,1 on /usr/local/bin/pyuic4
Comment 4 Rainer Hurling freebsd_committer 2018-03-11 07:55:55 UTC
Yup, I think, Loïc is right.

It does not work, if py27 and py3* should be installed at the same time. And, problably this must be solved for py-qt5-core and py-qt4-core.

IMO, something like in #219641, comment #33 is needed to solve this?
Comment 5 Rainer Hurling freebsd_committer 2018-03-11 07:57:15 UTC
(In reply to Rainer Hurling from comment #4)
Sorry, the link is broken. Should be bug #219641, comment #33
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-09-30 20:28:37 UTC
ping!
Comment 7 Tobias C. Berner freebsd_committer 2018-09-30 20:37:32 UTC
It's on the to-do list.
Comment 8 Tobias C. Berner freebsd_committer 2018-10-27 12:19:23 UTC
See:

https://reviews.freebsd.org/D8714

*** This bug has been marked as a duplicate of bug 219641 ***