Bug 223776 - ports-mgmt/pkg: lld confuses shared library tracking
Summary: ports-mgmt/pkg: lld confuses shared library tracking
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ed Maste
URL: https://github.com/freebsd/pkg/pull/1636
Keywords:
Depends on:
Blocks: 214864
  Show dependency treegraph
 
Reported: 2017-11-20 23:32 UTC by Jan Beich
Modified: 2017-12-18 19:04 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (pkg)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-11-20 23:32:41 UTC
$ ld.lld -V
LLD 5.0.0 (FreeBSD 312559) (compatible with GNU linkers)
$ pkg -v
1.10.2

$ pkg install firefox mesa-dri
$ pkg delete -f glib
$ ln -fs ld.lld /usr/bin/ld
$ make install -C /usr/ports/devel/glib20
$ pkg check -d
Checking all packages: 100%
at-spi2-atk is missing a required shared library: libgobject-2.0.so.0
at-spi2-atk is missing a required shared library: libgmodule-2.0.so.0
at-spi2-core is missing a required shared library: libgobject-2.0.so.0
at-spi2-core is missing a required shared library: libgio-2.0.so.0
atk is missing a required shared library: libgobject-2.0.so.0
avahi-app is missing a required shared library: libgobject-2.0.so.0
cairo is missing a required shared library: libgobject-2.0.so.0
colord is missing a required shared library: libgobject-2.0.so.0
colord is missing a required shared library: libgmodule-2.0.so.0
colord is missing a required shared library: libgthread-2.0.so.0
colord is missing a required shared library: libgio-2.0.so.0
dbus-glib is missing a required shared library: libgobject-2.0.so.0
dbus-glib is missing a required shared library: libgio-2.0.so.0
firefox is missing a required shared library: libgio-2.0.so.0
firefox is missing a required shared library: libgobject-2.0.so.0
gdk-pixbuf2 is missing a required shared library: libgobject-2.0.so.0
gdk-pixbuf2 is missing a required shared library: libgmodule-2.0.so.0
gdk-pixbuf2 is missing a required shared library: libgio-2.0.so.0
gobject-introspection is missing a required shared library: libgobject-2.0.so.0
gobject-introspection is missing a required shared library: libgio-2.0.so.0
gobject-introspection is missing a required shared library: libgmodule-2.0.so.0
gtk-update-icon-cache is missing a required shared library: libgobject-2.0.so.0
gtk2 is missing a required shared library: libgobject-2.0.so.0
gtk2 is missing a required shared library: libgmodule-2.0.so.0
gtk2 is missing a required shared library: libgio-2.0.so.0
gtk3 is missing a required shared library: libgmodule-2.0.so.0
gtk3 is missing a required shared library: libgio-2.0.so.0
gtk3 is missing a required shared library: libgobject-2.0.so.0
harfbuzz is missing a required shared library: libgobject-2.0.so.0
pango is missing a required shared library: libgobject-2.0.so.0
pango is missing a required shared library: libgthread-2.0.so.0
polkit is missing a required shared library: libgobject-2.0.so.0
polkit is missing a required shared library: libgmodule-2.0.so.0
polkit is missing a required shared library: libgio-2.0.so.0
Comment 1 Tobias Kortkamp freebsd_committer 2017-11-21 00:22:49 UTC
I get this too.  The packages seem to miss shlibs_provided in their
manifests.

I've built an entire package set with lld as the default linker.  This
lead to weird results when running pkg upgrade or even pkg install.
E.g. on my notebook pkg insisted on always installing nvidia-driver on
every pkg install.  I'm assuming this was because pkg thinks it is the
only provider for libGL.so.1.  pkg check -d output is also pretty
scary.  I switched back to ld.bfd and the problem is gone.

Weirdly enough this didn't affect all packages but only some like
e.g.  mesa-libs, qt5-widgets, qt5-gui, libressl, libevent, readline,
...
Comment 2 Ed Maste freebsd_committer 2017-11-21 21:28:48 UTC
Fix in pull request 1636
Comment 3 Ed Maste freebsd_committer 2017-12-05 18:59:45 UTC
This should be fixed in pkg 1.10.3
Comment 4 Ed Maste freebsd_committer 2017-12-18 19:04:03 UTC
Fixed in pkg 1.10.3