Bug 223807 - archivers/rar: confuses build time checks with runtime checks
Summary: archivers/rar: confuses build time checks with runtime checks
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-23 01:11 UTC by Peter Wemm
Modified: 2019-09-02 21:44 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gabor)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Wemm freebsd_committer freebsd_triage 2017-11-23 01:11:00 UTC
[00:00:12] [05] [00:00:00] Finished archivers/rar | rar-5.5.0,3: Ignored: requires 32-bit libraries installed under /usr/lib32

The problem is that this is a build time check and not an install-time check.  It was quite possible to build on a system without lib32, and install and use the resulting package on a machine that did have lib32.

The lib32 build-time vs install-time checks are exactly reversed.

In the meantime, I've removed it from the freebsd.org cluster as it's now causing unnecessary build failures.
Comment 1 Alexey Dokuchaev freebsd_committer 2017-11-29 14:11:36 UTC
Some feedback from bapt@:

<bapt> unfortunately we have no solutions for that 
<bapt> all we can do is maybe a warning at install time
<bapt> something like in post install: if sysctl
       kern.features.compat_freebsd_32bit==1 and /usr/lib32 exist
<bapt> ok
<bapt> else kern.features.compat_freebsd_32bit==0 your kernel does not
       support 32-bit emulation
<bapt> else /usr/lib32/libc.so does not exist, cannot run
<bapt> fi
<bapt> something like that
<bapt> in the future we could prevent installation, but right now we
<bapt> should not
Comment 2 Rene Ladan freebsd_committer 2019-09-02 20:19:17 UTC
Maintainer reset.
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-09-02 21:44:19 UTC
I think this PR could be closed. danfe@ removed HAVE_COMPAT_IA32_KERN check in r453662. And I changed to upstream amd64/i386 binary since r494093. Please feel free to reopen it if the problem persists.