Bug 223811 - Uses/php.mk missing sodium dependency
Summary: Uses/php.mk missing sodium dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Torsten Zuehlsdorff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-23 07:28 UTC by Daniel Ylitalo
Modified: 2017-12-07 16:44 UTC (History)
3 users (show)

See Also:


Attachments
Fixing sodium dependency (441 bytes, patch)
2017-11-23 07:28 UTC, Daniel Ylitalo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Ylitalo 2017-11-23 07:28:58 UTC
Created attachment 188205 [details]
Fixing sodium dependency

There is a missing dependency line since php 7.2 was added, provided patch fixes that.

The issue becomes apparent when trying to build lang/php72-extensions with sodium checked
Comment 1 Torsten Zuehlsdorff freebsd_committer 2017-11-24 10:27:26 UTC
@ale: The diff looks fine to me. I can reproduce the error and that the patch fixes it.

Can you please approve it?
Comment 2 commit-hook freebsd_committer 2017-12-07 16:41:04 UTC
A commit references this bug:

Author: tz
Date: Thu Dec  7 16:40:20 UTC 2017
New revision: 455738
URL: https://svnweb.freebsd.org/changeset/ports/455738

Log:
  Uses/php.mk: add missing sodium dependency

  The issue becomes apparent when trying to build lang/php72-extensions
  with sodium checked.

  PR:           223811
  Submitted by: Daniel Ylitalo <daniel@blodan.se>
  Approved by:  ale

Changes:
  head/Mk/Uses/php.mk
Comment 3 Torsten Zuehlsdorff freebsd_committer 2017-12-07 16:44:55 UTC
ale approved per email. Committed, thanks :)