Bug 223814 - dns/gdnsd2: enable libmaxminddb for geoip2 database support.
Summary: dns/gdnsd2: enable libmaxminddb for geoip2 database support.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ryan Steinmetz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-23 10:24 UTC by Peter Wemm
Modified: 2017-11-23 21:35 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (zi)


Attachments
Patch to add libmaxminddb to the build. (798 bytes, patch)
2017-11-23 10:24 UTC, Peter Wemm
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Wemm freebsd_committer freebsd_triage 2017-11-23 10:24:45 UTC
Created attachment 188210 [details]
Patch to add libmaxminddb to the build.

gdnsd2 prefers libmaxminddb over libGeoIP if it is present. It would be nice to be able to configure the package build to do that.

Half-baked patch attached.  I added a radio option to pick one or the other, or neither.  libmaxminddb appears to be able to read the old .dat and the new .mmdb files just fine and appears to be a strict superset of GeoIP so I set it to be the default.

Caveat: I changed GeoIP from a run depends to lib depends. I'm not sure if run depends was intended.
Comment 1 commit-hook freebsd_committer 2017-11-23 21:35:43 UTC
A commit references this bug:

Author: zi
Date: Thu Nov 23 21:35:00 UTC 2017
New revision: 454804
URL: https://svnweb.freebsd.org/changeset/ports/454804

Log:
  - Add libmaxminddb for geoip2 support
  - Bump PORTREVISION

  PR:		223814
  Submitted by:	peter@

Changes:
  head/dns/gdnsd2/Makefile