Bug 223844 - devel/ocl-icd: CommandLine Error: Option 'enable-value-profiling' registered more than once!
Summary: devel/ocl-icd: CommandLine Error: Option 'enable-value-profiling' registered ...
Status: Closed DUPLICATE of bug 223879
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-24 15:38 UTC by O. Hartmann
Modified: 2017-12-25 12:46 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2017-11-24 15:38:15 UTC
When using more than one installed OpenCL ICD, in my case 

ll /usr/local/etc/OpenCL/vendors/
321232 -rw-r--r--  1 root  wheel  -   33B 24 Nov. 14:24 intel-beignet.icd
321144 -rw-r--r--  1 root  wheel  -   19B 10 Nov. 15:05 mesa.icd
321060 -rw-r--r--  1 root  wheel  -   31B 24 Nov. 12:02 pocl.icd

a OpenCL client like clinfo (devel/clinfo) reports an error:

clinfo
: CommandLine Error: Option 'enable-value-profiling' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options

This error occurs also with any software compiled with lang/pocl.

Searching the net for this specific error reveals problems going back to January of 2017, i.e.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=852746
Comment 1 Bugzilla Automation freebsd_committer 2017-11-24 15:38:15 UTC
Maintainer informed via mail
Comment 2 O. Hartmann 2017-12-25 12:46:35 UTC

*** This bug has been marked as a duplicate of bug 223879 ***