Bug 223872 (cmake-3.10.0) - [exp-run] devel/cmake update to 3.10.1
Summary: [exp-run] devel/cmake update to 3.10.1
Status: Closed FIXED
Alias: cmake-3.10.0
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Adriaan de Groot
URL: https://reviews.freebsd.org/D13210
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-25 20:16 UTC by Adriaan de Groot
Modified: 2017-12-23 10:45 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)
antoine: exp-run+


Attachments
Patch against ports r454892 (39.05 KB, patch)
2017-11-25 20:16 UTC, Adriaan de Groot
no flags Details | Diff
Updated patch against ports r456601 (44.12 KB, patch)
2017-12-18 08:53 UTC, Adriaan de Groot
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adriaan de Groot freebsd_committer 2017-11-25 20:16:13 UTC
Created attachment 188280 [details]
Patch against ports r454892

kde@ would like to ask for an exp-run to test the update of CMake to the latest upstream version, 3.10.0.
Comment 1 Antoine Brodin freebsd_committer 2017-11-27 18:36:34 UTC
New failures on 10.3 i386:

+ {"origin"=>"cad/openvsp", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"deskutils/kdepim4", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"math/scalapack", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"multimedia/qmmp", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"multimedia/qmmp-qt5", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"www/qt5-webkit", "phase"=>"configure", "errortype"=>"???"}

http://package23.nyi.freebsd.org/data/103i386-default-PR223872/2017-11-27_14h43m28s/logs/errors/openvsp-3.13.3_1.log
http://package23.nyi.freebsd.org/data/103i386-default-PR223872/2017-11-27_14h43m28s/logs/errors/kdepim-4.14.10_9.log
http://package23.nyi.freebsd.org/data/103i386-default-PR223872/2017-11-27_14h43m28s/logs/errors/scalapack-2.0.2_12.log
http://package23.nyi.freebsd.org/data/103i386-default-PR223872/2017-11-27_14h43m28s/logs/errors/qmmp-0.10.10_1.log
http://package23.nyi.freebsd.org/data/103i386-default-PR223872/2017-11-27_14h43m28s/logs/errors/qmmp-qt5-1.1.10_1.log
http://package23.nyi.freebsd.org/data/103i386-default-PR223872/2017-11-27_14h43m28s/logs/errors/qt5-webkit-5.212.0.a2_4.log
Comment 2 Antoine Brodin freebsd_committer 2017-11-27 18:39:01 UTC
New failures on 10.3 amd64:

+ {"origin"=>"cad/openvsp", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"deskutils/kdepim4", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"math/scalapack", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"multimedia/qmmp", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"multimedia/qmmp-qt5", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"www/qt5-webkit", "phase"=>"configure", "errortype"=>"???"}
Comment 3 Adriaan de Groot freebsd_committer 2017-12-11 12:29:21 UTC
openvsp can be fixed w/ https://reviews.freebsd.org/D13439

scalapack is a new bug; might be workaroundable, upstream bug https://gitlab.kitware.com/cmake/cmake/issues/17552
Comment 4 Adriaan de Groot freebsd_committer 2017-12-11 13:22:58 UTC
qmmp, qmmp-qt5 fixed with new upstream releases, in ports r455412
Comment 5 Adriaan de Groot freebsd_committer 2017-12-11 17:56:12 UTC
kdepim4 and qt5-webkit can't reproduce locally with poudriere
Comment 6 Antoine Brodin freebsd_committer 2017-12-12 07:04:57 UTC
(In reply to Adriaan de Groot from comment #5)
Those failures definitely reproduced on the exp-builders when the exp-run was done.
Comment 7 Adriaan de Groot freebsd_committer 2017-12-18 08:53:37 UTC
Created attachment 188924 [details]
Updated patch against ports r456601
Comment 8 Adriaan de Groot freebsd_committer 2017-12-18 09:01:56 UTC
kde@ would like to request a new exp-run with the attached patch.
 - updates to devel/cmake 3.10.1 which has been released in the meantime
 - adds fixes for kdepim4, qt5-webkit
 - adds fix for openvsp
 - adds fix for scalapack (which I'm not really happy with)

No local build failures on 11.1 amd64
Comment 9 Antoine Brodin freebsd_committer 2017-12-22 15:24:46 UTC
Exp-run looks fine.
Comment 10 Adriaan de Groot freebsd_committer 2017-12-23 10:45:14 UTC
Fixed in revision 457041.
Comment 11 commit-hook freebsd_committer 2017-12-23 10:45:26 UTC
A commit references this bug:

Author: adridg
Date: Sat Dec 23 10:44:24 UTC 2017
New revision: 457041
URL: https://svnweb.freebsd.org/changeset/ports/457041

Log:
  Update CMake to 3.10.1

   - https://blog.kitware.com/cmake-3-10-1-available-for-download/
     - flang support
     - changes to automoc policies
     - support for FreeBSD package generation with CPack

  Necessary fixes to other ports:
   - cad/openvsp make search for libxml explicit
   - math/scalapack force C compiler to be compatible with mpi
   - deskutils/kdepim4 fix incorrect sources list
   - www/qt5-webkit fix incorrect sources list

  Thanks to Antoine for the multiple exp-runs.

  PR:		223872
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D13210

Changes:
  head/cad/openvsp/files/patch-src_vsp_CMakeLists.txt
  head/deskutils/kdepim4/files/patch-kdgantt2_CMakeLists.txt
  head/devel/cmake/Makefile
  head/devel/cmake/distinfo
  head/devel/cmake/files/InitialCache.cmake
  head/devel/cmake/pkg-plist
  head/devel/cmake-doc/Makefile
  head/devel/cmake-doc/pkg-plist
  head/devel/cmake-gui/Makefile
  head/math/scalapack/Makefile
  head/www/qt5-webkit/files/patch-git_14947c-fix_build_cmake_3.10