Bug 223873 - x11-fm/thunar: Update to 1.6.13
Summary: x11-fm/thunar: Update to 1.6.13
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jochen Neumeister
URL:
Keywords: patch-ready
Depends on:
Blocks:
 
Reported: 2017-11-25 20:29 UTC by Olivier Duchateau
Modified: 2017-11-27 14:45 UTC (History)
2 users (show)

See Also:
madpilot: maintainer-feedback+


Attachments
Patch to update x11-fm/thunar (859 bytes, patch)
2017-11-25 20:29 UTC, Olivier Duchateau
no flags Details | Diff
Patch to update x11-fm/thunar (1.07 KB, patch)
2017-11-25 22:09 UTC, Olivier Duchateau
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau 2017-11-25 20:29:27 UTC
Created attachment 188281 [details]
Patch to update x11-fm/thunar

Update to 1.6.13 (it is still Gtk2 application)
Comment 1 Jochen Neumeister freebsd_committer 2017-11-25 20:43:16 UTC
I added @madpilot.
Can we commit that? Or are there problems with https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=217510
Comment 2 Olivier Duchateau 2017-11-25 22:09:55 UTC
Created attachment 188283 [details]
Patch to update x11-fm/thunar

Update patch, because now it exists a devel release (1.7.x).
Comment 3 Guido Falsi freebsd_committer 2017-11-25 22:55:43 UTC
(In reply to Olivier Duchateau from comment #2)
> Created attachment 188283 [details]
> Patch to update x11-fm/thunar
> 
> Update patch, because now it exists a devel release (1.7.x).

(In reply to Jochen Neumeister from comment #1)
> I added @madpilot.
> Can we commit that? Or are there problems with
> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=217510

Hi,

Sorry but what's the connection between this and bug 217510? (it seems related to wordpress and PHP).


Apart from that I don't see a problem with this patch. (the newer one)

Since you took the bug I have no objection with you committing it, after proper testing.

I just noticed it and had no time to test it, I could do that tomorrow.
Comment 4 Jochen Neumeister freebsd_committer 2017-11-25 23:14:34 UTC
(In reply to Guido Falsi from comment #3)
108/5000
My mistake, I meant https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=217946

I will test the patch
Comment 5 Guido Falsi freebsd_committer 2017-11-25 23:18:35 UTC
(In reply to Jochen Neumeister from comment #4)
> (In reply to Guido Falsi from comment #3)
> 108/5000
> My mistake, I meant https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=217946
> 

There should be no problem with that.

I identified a few problems in devel/glib20 port, for which I posted a patch in bug 199872.

There is still an outstanding crash in the present thunar, for which I only have partial backtraces. I have been unable to reproduce that crash in a jail with debugging binaries for now.

There's a slight chance the new version actually fixes the problem...We will see.

> I will test the patch

Thanks!
Comment 6 Guido Falsi freebsd_committer 2017-11-25 23:20:08 UTC
> I identified a few problems in devel/glib20 port, for which I posted a patch
> in bug 199872.

I meant, problems in glib20 which cause thunar to crash.
Comment 7 commit-hook freebsd_committer 2017-11-27 14:45:15 UTC
A commit references this bug:

Author: joneum
Date: Mon Nov 27 14:45:04 UTC 2017
New revision: 454959
URL: https://svnweb.freebsd.org/changeset/ports/454959

Log:
  x11-fm/thunar: Update from 1.6.12 to 1.6.13

  Changelog:
   - Handle cases when file watch is not supported
   - Missing Trash Translation String
   - Delete Thunar symlink on uninstall
   - Handle g_mem_is_system_malloc deprecation
   - Prefer local (file://) URIs than native ones (e.g. smb://)
   - Translation updates: Amharic, Arabic, Asturian, Bangla, Basque, Belarusian,
     Bulgarian, Catalan, Chinese (China), Chinese (Hong Kong), Chinese (Taiwan),
     Croatian, Czech, Danish, Dutch, English (Australia), English (United Kingdom),
     Esperanto, Estonian, Finnish, French, Galician, German, Greek, Hebrew,
     Hungarian, Icelandic, Indonesian, Italian, Japanese, Kazakh, Korean, Latvian,
     Lithuanian, Malay, Norwegian Bokm?l, Norwegian Nynorsk, Occitan, Persian,
     Polish, Portuguese, Portuguese (Brazil), Punjabi, Romanian, Russian, Serbian,
     Slovak, Spanish, Swedish, Telugu, Thai, Turkish, Ukrainian, Urdu,
     Urdu (Pakistan), Uyghur, Vietnamese

  PR:		223873
  Submitted by:	duchateau.olivier@gmail.com
  Approved by:	madpilot (for @xfce), rene (mentor)
  Differential Revision:	https://reviews.freebsd.org/D13257

Changes:
  head/x11-fm/thunar/Makefile
  head/x11-fm/thunar/distinfo
Comment 8 Jochen Neumeister freebsd_committer 2017-11-27 14:45:42 UTC
thanks, landed :-)