Bug 223938 - multimedia/ffmpeg build error
Summary: multimedia/ffmpeg build error
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-multimedia mailing list
URL:
Keywords:
: 223936 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-28 13:16 UTC by flfq
Modified: 2017-12-02 10:20 UTC (History)
1 user (show)

See Also:
riggs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flfq 2017-11-28 13:16:00 UTC
/usr/include/asm/types.h:44:28: note: previous definition is here
typedef unsigned long long __u64;
                           ^
In file included from libavdevice/v4l2-common.c:19:
In file included from libavdevice/v4l2-common.h:36:
/usr/local/include/linux/videodev2.h:80:17: error: typedef redefinition with different types ('int64_t' (aka 'long') vs 'long long')
typedef int64_t __s64;
Comment 1 Jan Beich freebsd_committer 2017-11-28 13:37:29 UTC
(In reply to flfq from comment #0)
> /usr/include/asm/types.h:44:28: note: previous definition is here
> typedef unsigned long long __u64;

What FreeBSD version you're using that installs <asm/types.h>?
Comment 2 flfq 2017-11-28 14:00:13 UTC
(In reply to Jan Beich from comment #1)
I don't know which port is installed automatically

freebsd 11.0
3 servers all show this error
Comment 3 Jan Beich freebsd_committer 2017-11-28 14:12:43 UTC
(In reply to flfq from comment #2)
> I don't know which port is installed automatically

Ports are strongly discouraged to install stuff outside of PREFIX (i.e., /usr/local). Maybe check which package the file belongs to:

  $ pkg which /usr/include/asm/types.h

If the result is negative repopulate /usr/include by

  $ mv /usr/include /usr/include.old
  $ make distrib-dirs installincludes -C /usr/src
  $ diff -ur /usr/include.old /usr/include
  $ rm -rf /usr/include.old

Obviously, /usr/src have to be in sync with the installed system.
Comment 4 flfq 2017-11-28 14:51:54 UTC
(In reply to Jan Beich from comment #3)
I think it's probably because of my system upgrade.

the new os build is ok

thanks
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2017-11-28 16:35:56 UTC
*** Bug 223936 has been marked as a duplicate of this bug. ***