Bug 223992 - mail/dcc-dccd: update to 1.3.163, switch to https
Summary: mail/dcc-dccd: update to 1.3.163, switch to https
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Piotr Kubaj
URL:
Keywords:
: 237354 (view as bug list)
Depends on:
Blocks: 237354
  Show dependency treegraph
 
Reported: 2017-11-30 13:29 UTC by Piotr Kubaj
Modified: 2019-06-10 20:05 UTC (History)
4 users (show)

See Also:
pkubaj: maintainer-feedback+


Attachments
patch (1.26 KB, patch)
2017-11-30 13:29 UTC, Piotr Kubaj
no flags Details | Diff
patch (1.26 KB, patch)
2017-12-07 15:21 UTC, Piotr Kubaj
pkubaj: maintainer-approval+
Details | Diff
patch (1.26 KB, patch)
2018-03-12 14:20 UTC, Piotr Kubaj
pkubaj: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2017-11-30 13:29:10 UTC
Created attachment 188426 [details]
patch

This patch updates the port to 1.3.161. It also removes ftp mirror (with ftp being plaintext) and switches to https. 

Builds fine on Poudriere on 10.3-RELEASE and runs fine on 11.1-STABLE.
Comment 1 Piotr Kubaj freebsd_committer 2017-12-07 15:21:35 UTC
Created attachment 188614 [details]
patch

Updated for 1.3.162.
Comment 2 Steve Wills freebsd_committer 2017-12-11 21:49:42 UTC
Building this in poudriere with bulk -t, it seems there are some leftover files:

%%DCCUSER%%/ids.nopasswd
%%DCCUSER%%/map.nopasswd
%%DCCUSER%%/map.txt.nopasswd

Should those be added to the plist or should something be patched to not install them?
Comment 3 Piotr Kubaj freebsd_committer 2017-12-16 15:01:43 UTC
(In reply to Steve Wills from comment #2)
These files are generated by pkg-install.in and are already present in 1.3.159 (which is in ports). Either way, make check-plist says it's ok.
Comment 4 Piotr Kubaj freebsd_committer 2018-03-12 14:20:06 UTC
Created attachment 191449 [details]
patch

Updated patch for 1.3.163.

Tested on 10.4-RELEASE.
Comment 5 Tobias Kortkamp freebsd_committer 2019-04-30 15:46:24 UTC
*** Bug 237354 has been marked as a duplicate of this bug. ***
Comment 6 Tobias Kortkamp freebsd_committer 2019-04-30 15:46:59 UTC
Assign to maintainer who has a commit bit now.