Bug 224089 - databases/mariadb101-server and databases/mariadb102-server: fails to build with boost 1.66 (OQGRAPH=on)
Summary: databases/mariadb101-server and databases/mariadb102-server: fails to build w...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bernard Spil
URL: https://jira.mariadb.org/browse/MDEV-...
Keywords: needs-patch
Depends on:
Blocks: 223922
  Show dependency treegraph
 
Reported: 2017-12-04 17:50 UTC by Jan Beich
Modified: 2018-02-15 16:53 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (brnrd)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-12-04 17:50:37 UTC
As part of exp-run in bug 223922 this port was found to break on Boost update. If the issue won't disappear on its own by Boost release I plan to mark OQGRAPH option as BROKEN. Can you check with upstream maintainer or help with a fix?

$ fetch -qo- 'https://reviews.freebsd.org/D13279?download=true' | patch -Efsp0 -d /usr/ports
$ make all deinstall install clean -C/usr/ports/devel/boost-libs
$ make -C/usr/ports/comms/usrp
[...]
In file included from storage/oqgraph/graphcore.cc:29:
In file included from storage/oqgraph/graphcore-graph.h:28:
In file included from storage/oqgraph/oqgraph_shim.h:28:
storage/oqgraph/oqgraph_judy.h:66:24: error: too few arguments provided to function-like macro invocation
        return setbit(n);
                       ^
/usr/include/sys/param.h:285:9: note: macro 'setbit' defined here
#define setbit(a,i)     (((unsigned char *)(a))[(i)/NBBY] |= 1<<((i)%NBBY))
        ^
In file included from storage/oqgraph/graphcore.cc:29:
In file included from storage/oqgraph/graphcore-graph.h:28:
In file included from storage/oqgraph/oqgraph_shim.h:28:
storage/oqgraph/oqgraph_judy.h:118:36: error: too few arguments provided to function-like macro invocation
    judy_bitset& setbit(size_type n);
                                   ^
/usr/include/sys/param.h:285:9: note: macro 'setbit' defined here
#define setbit(a,i)     (((unsigned char *)(a))[(i)/NBBY] |= 1<<((i)%NBBY))
        ^
In file included from storage/oqgraph/graphcore.cc:29:
In file included from storage/oqgraph/graphcore-graph.h:28:
In file included from storage/oqgraph/oqgraph_shim.h:28:
storage/oqgraph/oqgraph_judy.h:38:5: error: constructor for 'open_query::judy_bitset' must explicitly initialize the reference member 'setbit'
    judy_bitset()
    ^
storage/oqgraph/oqgraph_judy.h:118:18: note: declared here
    judy_bitset& setbit(size_type n);
                 ^
storage/oqgraph/oqgraph_judy.h:42:5: error: constructor for 'open_query::judy_bitset' must explicitly initialize the reference member 'setbit'
    judy_bitset(const judy_bitset& src)
    ^
storage/oqgraph/oqgraph_judy.h:118:18: note: declared here
    judy_bitset& setbit(size_type n);
                 ^

http://package23.nyi.freebsd.org/data/103i386-default-PR223922/2017-12-02_11h06m37s/logs/errors/mariadb101-server-10.1.29.log
http://package22.nyi.freebsd.org/data/103amd64-default-PR223922/2017-12-02_11h06m39s/logs/errors/mariadb101-server-10.1.29.log
http://package22.nyi.freebsd.org/data/111amd64-default-PR223922/2017-12-03_09h31m05s/logs/errors/mariadb101-server-10.1.29.log
http://package23.nyi.freebsd.org/data/111i386-default-PR223922/2017-12-03_09h31m14s/logs/errors/mariadb101-server-10.1.29.log
Comment 2 Jan Beich freebsd_committer 2017-12-04 17:55:21 UTC
(In reply to Jan Beich from comment #0)
> $ make -C/usr/ports/comms/usrp

This was a typo, databases/mariadb101-server obviously. I was using a template to file such bugs.
Comment 3 Bernard Spil freebsd_committer 2018-02-13 11:18:10 UTC
Doubt that this is caused by boost. Looks like OQGraph is broken on setbit, can only check if this is solved upstream. Upstream ticket added for reference
https://jira.mariadb.org/browse/MDEV-15291
Comment 4 commit-hook freebsd_committer 2018-02-13 16:33:53 UTC
A commit references this bug:

Author: brnrd
Date: Tue Feb 13 16:33:06 UTC 2018
New revision: 461711
URL: https://svnweb.freebsd.org/changeset/ports/461711

Log:
  databases/mariadb101-server: unbreak OQGraph engine

   - Fixes collision in setbit with sys/param.h

  PR:		224089
  Reported by:	jbeich

Changes:
  head/databases/mariadb101-server/Makefile
  head/databases/mariadb101-server/files/patch-oqgraph-MDEV-15291
Comment 5 commit-hook freebsd_committer 2018-02-13 16:43:02 UTC
A commit references this bug:

Author: brnrd
Date: Tue Feb 13 16:42:32 UTC 2018
New revision: 461712
URL: https://svnweb.freebsd.org/changeset/ports/461712

Log:
  databases/mariadb100-server: unbreak OQGraph engine

   - Fixes collision in setbit with sys/param.h [1]
   - Add option to add unixODBC and xml feature to CONNECT engine

  PR:		224089
  Reported by:	jbeich

Changes:
  head/databases/mariadb100-server/Makefile
  head/databases/mariadb100-server/files/patch-oqgraph-MDEV-15291
Comment 6 commit-hook freebsd_committer 2018-02-13 17:47:58 UTC
A commit references this bug:

Author: brnrd
Date: Tue Feb 13 17:47:50 UTC 2018
New revision: 461733
URL: https://svnweb.freebsd.org/changeset/ports/461733

Log:
  databases/mariadb102-server: Security update to 10.2.13

   - Unbreak OQGraph engine [1]
          (collision in setbit with sys/param.h)

  PR:             224089 [1]
  Reported by:	jbeich
  MFH:		2018Q1
  Security:	e3445736-fd01-11e7-ac58-b499baebfeaf

Changes:
  head/databases/mariadb102-client/Makefile
  head/databases/mariadb102-server/Makefile
  head/databases/mariadb102-server/distinfo
  head/databases/mariadb102-server/files/patch-oqgraph-MDEV-15291
  head/databases/mariadb102-server/pkg-plist
Comment 7 commit-hook freebsd_committer 2018-02-15 16:53:00 UTC
A commit references this bug:

Author: brnrd
Date: Thu Feb 15 16:52:21 UTC 2018
New revision: 461933
URL: https://svnweb.freebsd.org/changeset/ports/461933

Log:
  MFH: r461733

  databases/mariadb102-server: Security update to 10.2.13

   - Unbreak OQGraph engine [1]
          (collision in setbit with sys/param.h)

  PR:             224089 [1]
  Reported by:	jbeich
  Security:	e3445736-fd01-11e7-ac58-b499baebfeaf

  Approved by:	ports-secteam (riggs)

Changes:
_U  branches/2018Q1/
  branches/2018Q1/databases/mariadb102-client/Makefile
  branches/2018Q1/databases/mariadb102-server/Makefile
  branches/2018Q1/databases/mariadb102-server/distinfo
  branches/2018Q1/databases/mariadb102-server/files/patch-oqgraph-MDEV-15291
  branches/2018Q1/databases/mariadb102-server/pkg-plist