Bug 224235 - graphics/inventor: Please add SONAME to libInventor.so
Summary: graphics/inventor: Please add SONAME to libInventor.so
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-11 07:27 UTC by Yuri Victorovich
Modified: 2019-09-07 08:56 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2017-12-11 07:27:30 UTC
The dependency port graphics.osg complains:

> Error: /usr/local/lib/osgPlugins-3.5.9/osgdb_iv.so is linked to /usr/local/lib/libInventor.so which does not have a SONAME.  graphics/inventor needs to be fixed.

Thanks!
Comment 1 Yuri Victorovich freebsd_committer 2018-07-22 20:33:57 UTC
Maintainer reset.
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-08-14 13:03:46 UTC
Port is marked BROKEN=         unfetchable.

I think we can Deprecate this port.
Comment 3 Yuri Victorovich freebsd_committer 2019-08-14 14:50:32 UTC
graphics/osg and graphics/osg-devel depend on it through their INVENTOR option.

Also, there is a runtime-conflict of graphics/inventor with some other package though I can't find it now. One of them includes the other one.

Also Debian, Fedora, MacPorts have packages for inventor: https://repology.org/project/inventor/versions
Comment 4 Yuri Victorovich freebsd_committer 2019-08-14 15:01:42 UTC
I asked the Fedora's inventor port long-time maintainer corsepiu@fedoraproject.org if he thinks that it should be deprecated.
Comment 5 Walter Schwarzenfeld freebsd_triage 2019-09-07 08:56:23 UTC
DEPRECATED=     Depends on expiring graphics/libGLw
EXPIRATION_DATE=        2019-11-01