Created attachment 188706 [details]
* Add pkg-message to SUB_FILES.
* Bump PORTREVISION.
Thank you for this bugfix!
Maintainer approved. Please commit this fix.
Created attachment 188871 [details]
updated patch file
* Simply move files/pkg-message.in to pkg-message because content of this file need not to be processed.
* Rename daily_status_security_baseaudit_* variables to security_status_baseaudit_* in files/405.pkg-base-audit.in because this file is not daily periodic script but security periodic script. Old daily_status_security_baseaudit_* variables are still available for backward compatibility. But warning messages are displayed if they are set explicitly in /etc/periodic.conf.
* Introduce security_status_baseaudit_period variable to files/405.pkg-base-audit.in in order to make it possible to specify when this script is executed (i.e. daily, weekly or monthly).
* Update pkg-message to reflect above 2 changes.
So please commit attached patch instead of original one.
And when committing updated patch, please take following steps.
1. cd /usr/ports/security/base-audit
2. svn move files/pkg-message.in pkg-message
3. svn patch /path/to/updated/patch
4. svn commit
(In reply to Miroslav Lachman from comment #1)
Thank you for approval. But I updated patch to introduce some improvements. So please check updated patch and approve it again if it is OK.
I am not strongly against these changes but... the script it-self imitates 410.pkg-audit (because it does the same thing for base, instead of packages)
If you look in to 410.pkg-audit (installed by pkg), you will see the same variable names with just s/pkgaudit/baseaudit/:
So I don't think it is good to change it in base-audit script.
Both are doing the same thing. It is not good for users to have these mixed in periodic.conf
(In reply to Miroslav Lachman from comment #4)
Thank you for feedback. I submitted following pull request to pkg repository on GitHub.
(In reply to Yasuhiro KIMURA from comment #5)
Thank you for your work!
If pkg devs will accept your proposal then it will make sense to change variable names in base-audit too.
We will see. ;)
(In reply to Miroslav Lachman from comment #6)
My pull request was merged by upstream. Just FYI.
(In reply to Yasuhiro KIMURA from comment #7)
Thank you for reminder.
I merged all your changes in to base-audit-0.2.
Tested with poudrier testport.
Please commit new port version.
Created attachment 189378 [details]
updated port version 0.2
Created attachment 189379 [details]
poudriere testport build log
A commit references this bug:
Date: Fri Jan 12 15:29:00 UTC 2018
New revision: 458854
security/base-audit: update 0.1 -> 0.2
- Introduce security_status_baseaudit_period variable to
files/405.pkg-base-audit.in in order to make it possible to specify
when this script is executed (i.e. daily, weekly or monthly).
Submitted by: Yasuhiro KIMURA <email@example.com>, Miroslav Lachman <firstname.lastname@example.org> (maintainer)