Bug 224387 - upgrade graphics/py-pygal
Summary: upgrade graphics/py-pygal
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Wen Heping
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-16 23:36 UTC by jjachuf
Modified: 2018-02-18 13:39 UTC (History)
1 user (show)

See Also:


Attachments
upgrade file (915 bytes, text/plain)
2017-12-16 23:36 UTC, jjachuf
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jjachuf 2017-12-16 23:36:57 UTC
Created attachment 188897 [details]
upgrade file

simple upgrade version (2.3.1 to 2.4.0)
Comment 1 Wen Heping freebsd_committer 2018-02-18 13:39:52 UTC
the build error, the error log is :

===>   py27-pygal-2.4.0 depends on package: py27-setuptools>0 - found
===>   py27-pygal-2.4.0 depends on file: /usr/local/bin/python2.7 - found
===>  Configuring for py27-pygal-2.4.0
Download error on https://pypi.python.org/simple/pytest-runner/: [Errno 8] hostname nor servname provided, or not known -- Some packages may not be found!
Couldn't find index page for 'pytest-runner' (maybe misspelled?)
Download error on https://pypi.python.org/simple/: [Errno 8] hostname nor servname provided, or not known -- Some packages may not be found!
No local packages or working download links found for pytest-runner
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 96, in <module>
    "Topic :: Multimedia :: Graphics :: Presentation"])
  File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py", line 128, in setup
    _install_setup_requires(attrs)
  File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py", line 123, in _install_setup_requires
    dist.fetch_build_eggs(dist.setup_requires)
  File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py", line 461, in fetch_build_eggs
    replace_conflicting=True,
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 866, in resolve
    replace_conflicting=replace_conflicting
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1146, in best_match
    return self.obtain(req, installer)
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1158, in obtain
    return installer(requirement)
  File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py", line 528, in fetch_build_egg
    return cmd.easy_install(req)
  File "/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 667, in easy_install
    raise DistutilsError(msg)
distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('pytest-runner')
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/py-pygal
build of graphics/py-pygal | py27-pygal-2.4.0 ended at Sun Feb 18 21:37:27 CST 2018
build time: 00:00:09
!!! build failure encountered !!!
[00:02:07] Error: Build failed in phase: configure

would you have a check of it ?