Bug 224465 - outdated https://www.freebsd.org/ports/finance.html page
Summary: outdated https://www.freebsd.org/ports/finance.html page
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Website (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Wolfram Schneider
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-19 17:16 UTC by Wolfram Schneider
Modified: 2020-07-27 19:44 UTC (History)
3 users (show)

See Also:


Attachments
ports makefile patch (665 bytes, patch)
2017-12-19 17:17 UTC, Wolfram Schneider
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfram Schneider freebsd_committer 2017-12-19 17:16:27 UTC
I got a bug report that https://www.freebsd.org/ports/finance.html is not up-to-date. The page will be updated apparently only once a week. The search script https://www.freebsd.org/cgi/ports.cgi use a database less than a day old.

Looking at en_US.ISO8859-1/htdocs/ports/Makefile I think the problem is that we do not check every time if there is a newer INDEX files is available. We run fetch(1) in mirror mode, but don't call it until ./INDEX was removed.

Attached is a patch to solve the issue.
Comment 1 Wolfram Schneider freebsd_committer 2017-12-19 17:17:27 UTC
Created attachment 188974 [details]
ports makefile patch
Comment 2 Glen Barber freebsd_committer 2017-12-19 17:37:10 UTC
(In reply to Wolfram Schneider from comment #1)
> Created attachment 188974 [details]
> ports makefile patch

This looks fine to me.
Comment 3 commit-hook freebsd_committer 2017-12-20 08:14:06 UTC
A commit references this bug:

Author: wosch
Date: Wed Dec 20 08:13:58 UTC 2017
New revision: 51323
URL: https://svnweb.freebsd.org/changeset/doc/51323

Log:
  always check if there is a newer INDEX database is available

  PR: 224465

Changes:
  head/en_US.ISO8859-1/htdocs/ports/Makefile
Comment 4 Wolfram Schneider freebsd_committer 2018-01-03 17:07:00 UTC
The page is still a little bit outdated. Today it says in the footer

Last modified: 31-December-2017

instead the expected 3-January-2017

I guess this happens because we are using the env variable PINDEX_OVERRIDE and the file  is outdated.
Comment 5 Jason Helfman freebsd_committer 2020-07-27 03:15:31 UTC
This may have been fixed...?

Last modified: 23-July-2020 as of today... 26-July-2020

-jgh