Bug 224482 - games/openspades: Update to 0.1.2
Summary: games/openspades: Update to 0.1.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-20 14:14 UTC by Kevin Zheng
Modified: 2019-01-11 21:11 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (amdmi3)


Attachments
Patch (5.63 KB, patch)
2017-12-20 14:14 UTC, Kevin Zheng
no flags Details | Diff
Patch (apply with patch -p0 < PATCH) (5.90 KB, patch)
2018-07-09 19:32 UTC, Kevin Zheng
no flags Details | Diff
Updated patch (5.98 KB, patch)
2019-01-04 04:27 UTC, Kevin Zheng
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Zheng 2017-12-20 14:14:52 UTC
Created attachment 188992 [details]
Patch

- Update to 0.1.1c and dependencies
- Update WWW
- Remove upstreamed patches
Comment 1 Dmitry Marakasov freebsd_committer 2017-12-25 16:26:11 UTC
Please submit as correct SVN patch.
Comment 2 Kevin Zheng 2017-12-31 01:38:16 UTC
(In reply to Dmitry Marakasov from comment #1)
I can't generate a `svn diff` because I'm not working from a SVN working directory and don't have the connectivity to checkout one right now. Have you tried `patch -p1` and then removing empty files?

GNU Patch (since 2.7) also knows how to deal with Git-style diffs. I can also give you a `diff -ruN` if you prefer.
Comment 3 Kevin Zheng 2018-07-09 19:32:22 UTC
Created attachment 195009 [details]
Patch (apply with patch -p0 < PATCH)

Update to 0.1.2. Apply with patch -p0 < PATCH.
Comment 4 Kevin Zheng 2018-09-26 22:56:33 UTC
Maintainer timeout of 2 months or 9 months, depending on how you count it.
Comment 5 Kevin Zheng 2019-01-04 04:27:05 UTC
Created attachment 200760 [details]
Updated patch
Comment 6 Dmitry Marakasov freebsd_committer 2019-01-10 16:36:12 UTC
Does not build on i386:

[131/268] /usr/local/libexec/ccache/c++  -DHAS_FCNTL=1 -DHAS_GETHOSTBYADDR_R=1 -DHAS_GETHOSTBYNAME_R=1 -DHAS_INET_NTOP=1 -DHAS_INET_PTON=1 -DHAS_MSGHDR_FLAGS=1 -DHAS_POLL=1 -DHAS_SOCKLEN_T=1 -I. -I/usr/local/include/SDL2 -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/opus -ISources/AngelScript/projects/cmake/../../include -O2 -pipe -fstack-protector -fno-strict-aliasing -std=gnu++11 -O3 -O2 -pipe -fstack-protector -fno-strict-aliasing   -Wall -Wextra -Wno-unused-parameter -D_CRT_SECURE_NO_WARNINGS -DANGELSCRIPT_EXPORT -D_LIB -MD -MT Sources/AngelScript/projects/cmake/CMakeFiles/Angelscript.dir/__/__/source/as_callfunc_x86.cpp.o -MF Sources/AngelScript/projects/cmake/CMakeFiles/Angelscript.dir/__/__/source/as_callfunc_x86.cpp.o.d -o Sources/AngelScript/projects/cmake/CMakeFiles/Angelscript.dir/__/__/source/as_callfunc_x86.cpp.o -c Sources/AngelScript/source/as_callfunc_x86.cpp
FAILED: Sources/AngelScript/projects/cmake/CMakeFiles/Angelscript.dir/__/__/source/as_callfunc_x86.cpp.o
/usr/local/libexec/ccache/c++  -DHAS_FCNTL=1 -DHAS_GETHOSTBYADDR_R=1 -DHAS_GETHOSTBYNAME_R=1 -DHAS_INET_NTOP=1 -DHAS_INET_PTON=1 -DHAS_MSGHDR_FLAGS=1 -DHAS_POLL=1 -DHAS_SOCKLEN_T=1 -I. -I/usr/local/include/SDL2 -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/opus -ISources/AngelScript/projects/cmake/../../include -O2 -pipe -fstack-protector -fno-strict-aliasing -std=gnu++11 -O3 -O2 -pipe -fstack-protector -fno-strict-aliasing   -Wall -Wextra -Wno-unused-parameter -D_CRT_SECURE_NO_WARNINGS -DANGELSCRIPT_EXPORT -D_LIB -MD -MT Sources/AngelScript/projects/cmake/CMakeFiles/Angelscript.dir/__/__/source/as_callfunc_x86.cpp.o -MF Sources/AngelScript/projects/cmake/CMakeFiles/Angelscript.dir/__/__/source/as_callfunc_x86.cpp.o.d -o Sources/AngelScript/projects/cmake/CMakeFiles/Angelscript.dir/__/__/source/as_callfunc_x86.cpp.o -c Sources/AngelScript/source/as_callfunc_x86.cpp
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
error: this directive must appear between .cfi_startproc and .cfi_endproc directives
fatal error: too many errors emitted, stopping now [-ferror-limit=]
Comment 7 Kevin Zheng 2019-01-10 16:42:10 UTC
(In reply to Dmitry Marakasov from comment #6)
I'll take a look. I don't have i386 so I can't test, but a cursory look suggests that this might be an issue upstream.
Comment 8 Dmitry Marakasov freebsd_committer 2019-01-10 19:47:50 UTC
It's caused by bundled angelscript. We could/should use one from ports, but honestly I don't want to bother now, so I'll mark this as amd64-only. Will commit after some playtesting.
Comment 9 commit-hook freebsd_committer 2019-01-11 20:50:46 UTC
A commit references this bug:

Author: amdmi3
Date: Fri Jan 11 20:50:19 UTC 2019
New revision: 490011
URL: https://svnweb.freebsd.org/changeset/ports/490011

Log:
  - Update to 0.1.2

  PR:		224482
  Submitted by:	kevinz5000@gmail.com

Changes:
  head/games/openspades/Makefile
  head/games/openspades/distinfo
  head/games/openspades/files/
  head/games/openspades/pkg-descr