Bug 224506 - net/asterisk13: Unable to chown run directory to 931 (asterisk) (/var/run on tmpfs)
Summary: net/asterisk13: Unable to chown run directory to 931 (asterisk) (/var/run on ...
Status: Closed DUPLICATE of bug 224505
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-21 20:06 UTC by O. Hartmann
Modified: 2017-12-21 21:42 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (madpilot)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2017-12-21 20:06:46 UTC
Asterisk, most recent from the port, doesn't start properly when /var/run/asterisk resides on TMPFS - this is in our environment the case.

While booting, I watch this message appearing:

[...]
Starting asterisk.
Unable to chown run directory to 931 (asterisk)
meuh
prcmd

and ll /var/run gives

[...]
total 64
drwxr-xr-x  2 root        asterisk       0 Dec 16 16:26 asterisk/
[..]

The daemon asterisk is running, as one could easily proof via top, but trying to connect to asterisk via 

root@gate:~ # asterisk -rv
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)


fails in the shown error.

/usr/ports tree is: revision 456941

OS: 12.0-CURRENT FreeBSD 12.0-CURRENT #21 r327064: Thu Dec 21 18:50:24 CET 2017 amd64
Comment 1 Guido Falsi freebsd_committer 2017-12-21 21:42:00 UTC

*** This bug has been marked as a duplicate of bug 224505 ***