Bug 224557 - [acpi] FreeBSD 12-CURRENT r327038 on Dell Inspiron 7352: Reboot results in blank screen
Summary: [acpi] FreeBSD 12-CURRENT r327038 on Dell Inspiron 7352: Reboot results in bl...
Status: Closed DUPLICATE of bug 220727
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-acpi mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-24 00:05 UTC by Neel Chauhan
Modified: 2018-05-08 12:06 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan 2017-12-24 00:05:02 UTC
When I boot FreeBSD 12-CURRENT r327038 on a Dell Inspiron 7352 (i7-5500U, 8GB DDR3) and reboot, the screen lights up but ends up blank and not showing anything. This bug exists in both UEFI and Legacy mode, and existed as early as 9.1-RELEASE. Keep in mind that I have an aftermarket SSD (SanDisk X400 512GB 2.5") in this laptop. I also have this issue when booting from USB. Shutdowns work fine.

Another laptop, a HP EliteBook Folio 1040 G1 (which is my primary FreeBSD machine) also has a SanDisk M.2 SSD (SD6SN1M-256G-1006) although this SanDisk is a HP OEM part, and the 1040 not have this issue.

My desktop (homebuilt, Asus H87M-E motherboard) also has a SanDisk SSD (ReadyCache 64GB, don't remember exact model number) used for a ZFS cache, and the desktop does not have any problems with FreeBSD reboots either.

All 3 systems have UEFI with Secure Boot disabled and CSM enabled (in a hybrid UEFI/BIOS mode).

Keep in mind that both laptops and the desktop are personal (i.e. owned by me), the Dell is used for schoolwork and internship and the HP is used for personal stuff (including Port maintenance). I am hoping that I can use FreeBSD for my schoolwork as well instead of Linux and don't want to use my EliteBook for schoolwork.
Comment 1 Neel Chauhan 2018-02-11 01:16:23 UTC
A 128GB Kingston SSDNow 300 SSD also had this issue. On a Zotac BI323, this exact SSD did not have an issue. It's not an issue with Sandisk or Kingston, but with Dell and Insyde (who makes the UEFI in this system).
Comment 2 Neel Chauhan 2018-02-19 14:13:14 UTC
FreeBSD 12-CURRENT r329320 does not have this issue. Thank god!

However, 11-STABLE r329338 still has this issue. Maybe it has been patched in HEAD but hasn't been MFC'd yet.
Comment 3 Neel Chauhan 2018-03-23 01:35:15 UTC
Unfortunately, the issue came back with newer CURRENTs.

Someone else also had the same issue with recent ThinkPads: Bug 220727.
Comment 4 Neel Chauhan 2018-05-08 12:06:25 UTC
It appears this problem also appears on ThinkPad models like the X270, T470s, and X1 Carbon. Also, there is more progress on Bug 220727 (focuses on ThinkPads, but also mentions my Inspiron).

*** This bug has been marked as a duplicate of bug 220727 ***