Bug 224622 - www/chromium, www/iridium: switch to llvm50
Summary: www/chromium, www/iridium: switch to llvm50
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-chromium (Nobody)
URL:
Keywords: patch, patch-ready
Depends on: 224591
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-27 22:56 UTC by Jan Beich
Modified: 2017-12-29 00:43 UTC (History)
2 users (show)

See Also:
cpm: maintainer-feedback+


Attachments
v0 (3.81 KB, patch)
2017-12-27 22:56 UTC, Jan Beich
cpm: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-12-27 22:56:34 UTC
Created attachment 189143 [details]
v0

+++ This bug was initially created as a clone of Bug #224617 +++

Mesa, Beignet, gecko@, USES=compiler:c++14-lang already switched to devel/llvm50. Let's follow the suit. Would be nice if this lands before 2018Q1 branches. pkg-fallout@ will have at least 2 bulk builds before the year ends: Thursday at 01:00 UTC, Saturday at 01:00 UTC.

Only tested the most troublesome release/architecture tuple:
www/chromium built fine on 10.3 i386 - https://ptpb.pw/L0Li
www/iridium built fine on 10.3 i386  - https://ptpb.pw/fWhV

by watching a 2160p@60fps video on Youtube in a X11/GL jail.
Comment 1 Carlos J. Puga Medina freebsd_committer 2017-12-27 23:15:50 UTC
(In reply to Jan Beich from comment #0)

Jan,

If I recall correctly, chromium builds fine but fails to run because it is using the LLVM's LLD linker.

Can you confirm that chromium works on i386?

Thanks.
Comment 2 Jan Beich freebsd_committer 2017-12-27 23:21:10 UTC
(In reply to Carlos J. Puga Medina from comment #1)
> Can you confirm that chromium works on i386?

I've only tested on 10.3 i386 jail under 12.0 amd64 kernel. No clue about 10.4 i386, 11.1 i386 or 12.0 i386 jails.

These ports take a lot of time to build. Unless you suspect a regression we can land now then check binary packages in ~2 days for all supported tuples.
Comment 3 Jan Beich freebsd_committer 2017-12-27 23:22:53 UTC
What else besides Youtube I should've tested runtime on? Viewing forums.freebsd.org also works fine.
Comment 4 Carlos J. Puga Medina freebsd_committer 2017-12-27 23:29:52 UTC
(In reply to Jan Beich from comment #3)

OK, the patch is ready to land.
Comment 5 Jan Beich freebsd_committer 2017-12-27 23:32:15 UTC
(In reply to Carlos J. Puga Medina from comment #1)
> ... because it is using the LLVM's LLD linker.

LLD from LLVM 5.0 is more stable due to FreeBSD project trying to dogfood it as the default linker (see bug 214864). However, some fixes didn't end up in devel/llvm50 which is based on official releases.

OK. I've checked /latest package and see the crash. Seems like we have an improvement rather than a regression. ;)
Comment 6 commit-hook freebsd_committer 2017-12-27 23:34:04 UTC
A commit references this bug:

Author: jbeich
Date: Wed Dec 27 23:33:05 UTC 2017
New revision: 457431
URL: https://svnweb.freebsd.org/changeset/ports/457431

Log:
  www/chromium, www/iridium: switch to llvm50 (like r457360)

  PR:		224622
  Approved by:	chromium (cpm)

Changes:
  head/www/chromium/Makefile
  head/www/chromium/files/patch-build_toolchain_gcc__toolchain.gni
  head/www/iridium/Makefile
  head/www/iridium/files/patch-build_toolchain_gcc__toolchain.gni
Comment 7 commit-hook freebsd_committer 2017-12-27 23:36:08 UTC
A commit references this bug:

Author: jbeich
Date: Wed Dec 27 23:35:21 UTC 2017
New revision: 457432
URL: https://svnweb.freebsd.org/changeset/ports/457432

Log:
  www/iridium: bump PORTREVISION after r457431

  PR:		224622
  Pointy hat to:	jbeich

Changes:
  head/www/iridium/Makefile
Comment 8 Jan Beich freebsd_committer 2017-12-28 04:41:15 UTC
chromium and iridium locally built on 11.1 i386 also ran fine unlike /latest package built by llvm40.
Comment 9 Jan Beich freebsd_committer 2017-12-29 00:34:30 UTC
10.3 i386/amd64 and 11.1 i386/amd64 binary packages built by llvm50 are already available for /latest set.
Comment 10 Carlos J. Puga Medina freebsd_committer 2017-12-29 00:43:36 UTC
Awesome! Thanks for the heads-up :)