Bug 224638 - New port: archivers/maxcso, ISO to CSO compressor for PSP/PS2 emulators
Summary: New port: archivers/maxcso, ISO to CSO compressor for PSP/PS2 emulators
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-28 13:22 UTC by Greg V
Modified: 2018-11-08 23:19 UTC (History)
1 user (show)

See Also:


Attachments
maxcso.patch (2.03 KB, patch)
2017-12-28 13:22 UTC, Greg V
no flags Details | Diff
maxcso.patch v2 (2.57 KB, patch)
2018-11-08 20:50 UTC, Greg V
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2017-12-28 13:22:00 UTC
Created attachment 189157 [details]
maxcso.patch

Does not link with bfd (complains about missing symbols IIRC), so I set -fuse-ld=lld. Would be nice to have a BFD_UNSAFE flag in the framework :)
Comment 1 Li-Wen Hsu freebsd_committer 2018-07-09 02:25:24 UTC
Does not build on 11: https://gist.github.com/lwhsu/6848f5eb4ab86f6b7ef4559f794d42d7
Comment 2 Greg V 2018-07-09 12:18:47 UTC
Hm, looks like 11.2-RELEASE has old lld..

I can reproduce this error in an old 11.1 jail, but copying /usr/bin/ld.lld from 11-STABLE fixes it.

The 11.2 release notes say "The clang, llvm, lldb and compiler-rt utilities have been updated to version 6.0.0", but looks like lld did not join the party :(
Comment 3 Greg V 2018-11-08 20:50:36 UTC
Created attachment 199086 [details]
maxcso.patch v2

This should work. (Just patching the makefile now.)
Comment 4 commit-hook freebsd_committer 2018-11-08 23:19:14 UTC
A commit references this bug:

Author: lwhsu
Date: Thu Nov  8 23:19:04 UTC 2018
New revision: 484487
URL: https://svnweb.freebsd.org/changeset/ports/484487

Log:
  Add maxcso, ISO to CSO compressor for PSP/PS2 emulators

  PR:		224638
  Submitted by:	Greg V <greg@unrelenting.technology>

Changes:
  head/archivers/Makefile
  head/archivers/maxcso/
  head/archivers/maxcso/Makefile
  head/archivers/maxcso/distinfo
  head/archivers/maxcso/files/
  head/archivers/maxcso/files/patch-Makefile
  head/archivers/maxcso/pkg-descr