Bug 224659 - graphics/mesa-dri: don't disable surfaceless
Summary: graphics/mesa-dri: don't disable surfaceless
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords: patch, regression
Depends on:
Blocks: 220982
  Show dependency treegraph
 
Reported: 2017-12-28 23:08 UTC by Jan Beich
Modified: 2018-10-16 00:04 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
v0 (1.44 KB, patch)
2017-12-28 23:08 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-12-28 23:08:46 UTC
Created attachment 189179 [details]
v0

WAYLAND=on build overrides the list of enabled platforms. Since Mesa 17.2.0 surfaceless platform was enabled by default upstream but WAYLAND option hasn't been adjusted. Notice -DHAVE_SURFACELESS_PLATFORM in build logs which disappears if WAYLAND option is enabled.

https://cgit.freedesktop.org/mesa/mesa/commit/?id=2d35773221
http://beefy5.nyi.freebsd.org/data/latest-per-pkg/mesa-dri/17.3.1/103i386-default.log
Comment 1 Jan Beich freebsd_committer 2017-12-28 23:16:17 UTC
The regression affects both WAYLAND=on and WAYLAND=off. I guess, the latter is to avoid accidentally picking up libwayland* as a dependency.
Comment 2 commit-hook freebsd_committer 2018-10-16 00:00:21 UTC
A commit references this bug:

Author: jbeich
Date: Tue Oct 16 00:00:09 UTC 2018
New revision: 482191
URL: https://svnweb.freebsd.org/changeset/ports/482191

Log:
  graphics/mesa-libs: enable surfaceless like upstream

  PR:		224659
  Approved by:	maintainer timeout (9 months)

Changes:
  head/graphics/mesa-libs/Makefile