Bug 224817 - mail/mairix: update to 0.24
Summary: mail/mairix: update to 0.24
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-01 13:26 UTC by Jose G. Juanino
Modified: 2018-02-20 18:55 UTC (History)
2 users (show)

See Also:
jjuanino: maintainer-feedback+


Attachments
update to 0.24 version (3.02 KB, patch)
2018-01-01 13:26 UTC, Jose G. Juanino
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jose G. Juanino 2018-01-01 13:26:07 UTC
Created attachment 189313 [details]
update to 0.24 version

Hi, I send a patch to update mail/mairix from 0.23 to 0.24 version.

Release notes: https://github.com/vandry/mairix/releases/tag/0.24

Important changes:

* Modified upstream. Now is a github user (vandry)
* SSL dependency is mandatory, as suggested by portlint
* pkg-plist added
* Patch to avoid error: use of undeclared identifier 'PF_UNSPEC'

The port has been tested, and works as expected.

Regards
Comment 1 Yuri Victorovich freebsd_committer 2018-02-20 18:54:52 UTC
Committed with changes.
Thank you for the update!
Comment 2 commit-hook freebsd_committer 2018-02-20 18:55:21 UTC
A commit references this bug:

Author: yuri
Date: Tue Feb 20 18:54:46 UTC 2018
New revision: 462417
URL: https://svnweb.freebsd.org/changeset/ports/462417

Log:
  mail/mairix: Update to 0.24

  Additional port changes:
  * Switched SF->GitHub
  * Added LICENSE_FILE
  * Added USES=ssl
  * Added the BSD patch (upstreamed)
  * Simplified *install target accordingly

  PR:		224817
  Submitted by:	jjuanino@gmail.com (maintainer)
  Approved by:	tcberner (mentor, implicit)

Changes:
  head/mail/mairix/Makefile
  head/mail/mairix/distinfo
  head/mail/mairix/files/
  head/mail/mairix/files/patch-imap.c
  head/mail/mairix/pkg-descr