Bug 224819 - x11-toolkits/tk87: tk87 conflicts with tk86
Summary: x11-toolkits/tk87: tk87 conflicts with tk86
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-tcltk (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-01 15:14 UTC by Ting-Wei Lan
Modified: 2018-01-04 08:57 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (tcltk)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ting-Wei Lan 2018-01-01 15:14:54 UTC
Installing tk87-8.7.a1...
pkg-static: tk87-8.7.a1 conflicts with tk86-8.6.7 (installs files into the same place).  Problematic file: /usr/local/libdata/pkgconfig/tk.pc

Is it an expected behavior, or it is a bug that can be fixed?
Comment 1 commit-hook freebsd_committer 2018-01-02 10:40:11 UTC
A commit references this bug:

Author: gahr
Date: Tue Jan  2 10:39:23 UTC 2018
New revision: 457841
URL: https://svnweb.freebsd.org/changeset/ports/457841

Log:
  lang/tcl86, x11-toolkits/tk86: update to 8.6.8

  Announcement: https://sourceforge.net/p/tcl/mailman/message/36166576/

  While at it, rename pkg-config files to avoid conflict with Tcl/Tk 8.7 [1].

  PR:		224819 [1]
  Reported by:	Ting-Wei Lan <lantw44@gmail.com>

Changes:
  head/lang/tcl86/Makefile
  head/lang/tcl86/distinfo
  head/lang/tcl86/files/patch-unix-Makefile.in
  head/lang/tcl86/files/patch-unix-tclUnixSock.c
  head/lang/tcl86/pkg-plist
  head/x11-toolkits/tk86/Makefile
  head/x11-toolkits/tk86/distinfo
  head/x11-toolkits/tk86/files/patch-Makefile.in
  head/x11-toolkits/tk86/pkg-plist
Comment 2 Ting-Wei Lan 2018-01-03 18:20:20 UTC
The renaming of tcl causes problem for tk:

$ pkg-config --modversion tk86
Package tcl was not found in the pkg-config search path.
Perhaps you should add the directory containing `tcl.pc'
to the PKG_CONFIG_PATH environment variable
Package 'tcl', required by 'tk86', not found

I wonder whether there are other projects that will be affected by this change if it is specific to FreeBSD ports.
Comment 3 commit-hook freebsd_committer 2018-01-04 08:55:22 UTC
A commit references this bug:

Author: gahr
Date: Thu Jan  4 08:54:46 UTC 2018
New revision: 458018
URL: https://svnweb.freebsd.org/changeset/ports/458018

Log:
  x11-toolkits/tk8[56]: adjust pkgconf files to reflect their tcl equivalents

  PR:		224819
  Reported by:	Ting-Wei Lan <lantw44@gmail.com>

Changes:
  head/x11-toolkits/tk85/Makefile
  head/x11-toolkits/tk86/Makefile
Comment 4 Pietro Cerutti freebsd_committer 2018-01-04 08:57:29 UTC
Thanks for pointing that out. I committed a fix to both tk85 and tk86. 
The issue was there for Tcl/Tk 8.5 since forever, and nobody's ever seemed to notice, so I guess I'll handle problems with specific packages as they come up.

Thanks!