Bug 224921 - devel/gnome-vfs does NOT need Kerberos (not needed check for kerberos)
Summary: devel/gnome-vfs does NOT need Kerberos (not needed check for kerberos)
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords: easy, patch-ready
Depends on:
Blocks:
 
Reported: 2018-01-05 03:16 UTC by Mikhail T.
Modified: 2018-03-09 09:43 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
Remove the pre-configure part with its bogus check for Kerberos (419 bytes, patch)
2018-01-05 03:16 UTC, Mikhail T.
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail T. 2018-01-05 03:16:52 UTC
Created attachment 189424 [details]
Remove the pre-configure part with its bogus check for Kerberos

Marcus added the check in 2007 -- maybe, Gnome was broken then and the check made some sense. It is not needed today -- I do not use Kerberos and build my world without it.

This triggers the bogus error message, which is best removed.
Comment 1 w.schwarzenfeld freebsd_triage 2018-03-08 17:29:20 UTC
Maintainer feedback, please!
Comment 2 w.schwarzenfeld freebsd_triage 2018-03-09 09:38:14 UTC
This was introuduce with PR 114838.

=> If one defines WITHOUT_KERBEROS="YES" in /etc/make.conf, then
=> gnome-vfs can no longer be built because libroken is missing.


This problem exists anymore. The check could removed.