Bug 224989 - Ports maintained by danfe@ broken by Clang 6
Summary: Ports maintained by danfe@ broken by Clang 6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords: needs-patch
Depends on:
Blocks: 224669
  Show dependency treegraph
 
Reported: 2018-01-08 11:57 UTC by Jan Beich
Modified: 2018-01-27 13:42 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-01-08 11:57:20 UTC
FreeBSD -CURRENT plans to update base Clang to 6.0.0 soon. While testing some of your ports failed to build:

astro/celestia
astro/celestia-gtk
astro/stellarium-qt4
benchmarks/glmark2
games/netradiant
games/yadex
graphics/lensfun
graphics/luxrender
graphics/luxrender14
sysutils/unetbootin

http://package18.nyi.freebsd.org/data/headamd64PR224669-default/2018-01-02_08h32m49s/logs/errors/celestia-glut-1.6.1_9.log
http://package18.nyi.freebsd.org/data/headamd64PR224669-default/2018-01-02_08h32m49s/logs/errors/yadex-1.7.0_2.log
http://package18.nyi.freebsd.org/data/headamd64PR224669-default/2018-01-02_08h32m49s/logs/errors/netradiant-20130630_8.log
http://package18.nyi.freebsd.org/data/headamd64PR224669-default/2018-01-02_08h32m49s/logs/errors/celestia-gtk-1.6.1_9.log
http://package18.nyi.freebsd.org/data/headamd64PR224669-default/2018-01-02_08h32m49s/logs/errors/luxrender-1.6_7.log
http://package18.nyi.freebsd.org/data/headamd64PR224669-default/2018-01-02_08h32m49s/logs/errors/glmark2-2014.03_1.log
http://package18.nyi.freebsd.org/data/headamd64PR224669-default/2018-01-02_08h32m49s/logs/errors/lensfun-0.3.2_1.log

http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/celestia-glut-1.6.1_9.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/celestia-gtk-1.6.1_9.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/glmark2-2014.03_1.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/lensfun-0.3.2_1.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/luxrender-1.6_7.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/luxrender14-1.4_7.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/netradiant-20130630_8.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/stellarium-qt4-0.12.9.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/unetbootin-657.log
http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/yadex-1.7.0_2.log

To reproduce:
$ poudriere jail -cj clang6-amd64 -a amd64 -v projects/clang600-import -m svn+https
$ poudriere bulk -Ctj clang6-amd64 benchmarks/glmark2 ...
Comment 1 commit-hook freebsd_committer 2018-01-15 11:38:38 UTC
A commit references this bug:

Author: danfe
Date: Mon Jan 15 11:38:03 UTC 2018
New revision: 459035
URL: https://svnweb.freebsd.org/changeset/ports/459035

Log:
  - Unbreak the build with new Clang version 6.0.0
  - Remove pre-r423928 WAF_CMD override for verbose logs

  PR:	224989

Changes:
  head/benchmarks/glmark2/Makefile
Comment 2 commit-hook freebsd_committer 2018-01-15 16:50:54 UTC
A commit references this bug:

Author: danfe
Date: Mon Jan 15 16:50:28 UTC 2018
New revision: 459080
URL: https://svnweb.freebsd.org/changeset/ports/459080

Log:
  - Unbreak the build against new Clang version 6.0.0
  - Merge all Clang-related fixes into existing patch and
    regenerate it to get sane timestamps while I'm here

  PR:	224989

Changes:
  head/games/netradiant/Makefile
  head/games/netradiant/files/patch-more-clang-fixes
Comment 3 commit-hook freebsd_committer 2018-01-15 16:54:01 UTC
A commit references this bug:

Author: danfe
Date: Mon Jan 15 16:53:05 UTC 2018
New revision: 459082
URL: https://svnweb.freebsd.org/changeset/ports/459082

Log:
  - Unbreak the build against new Clang version 6.0.0
  - While here, adjust COMMENT: Hexen support is limited

  PR:	224989

Changes:
  head/games/yadex/Makefile
Comment 4 commit-hook freebsd_committer 2018-01-15 18:17:34 UTC
A commit references this bug:

Author: danfe
Date: Mon Jan 15 18:17:14 UTC 2018
New revision: 459108
URL: https://svnweb.freebsd.org/changeset/ports/459108

Log:
  Unbreak the build against new Clang version 6.0.0.

  PR:	224989

Changes:
  head/sysutils/unetbootin/files/patch-unetbootin.cpp
Comment 5 commit-hook freebsd_committer 2018-01-15 18:42:59 UTC
A commit references this bug:

Author: danfe
Date: Mon Jan 15 18:42:10 UTC 2018
New revision: 459110
URL: https://svnweb.freebsd.org/changeset/ports/459110

Log:
  Unbreak the build against new Clang version 6.0.0 (due to the same nature
  of the changes, should've been part of r459108).

  PR:	224989

Changes:
  head/graphics/lensfun/Makefile
Comment 6 commit-hook freebsd_committer 2018-01-16 14:32:22 UTC
A commit references this bug:

Author: danfe
Date: Tue Jan 16 14:31:18 UTC 2018
New revision: 459176
URL: https://svnweb.freebsd.org/changeset/ports/459176

Log:
  Unbreak the build against new Clang version 6.0.0: struct FavoritesEntry
  defines its member `fov' of type `double'; comparing it to NULL is bogus
  and wrong, no wonder this upsets strict compilers.

  PR:	224989

Changes:
  head/astro/celestia/Makefile
Comment 7 commit-hook freebsd_committer 2018-01-16 16:04:41 UTC
A commit references this bug:

Author: danfe
Date: Tue Jan 16 16:03:39 UTC 2018
New revision: 459192
URL: https://svnweb.freebsd.org/changeset/ports/459192

Log:
  Unbreak the build with new Clang version 6.0.0: compare the pointer against
  NULL, not integer (or boolean) value.

  PR:	224989

Changes:
  head/astro/stellarium-qt4/Makefile
Comment 8 commit-hook freebsd_committer 2018-01-24 12:23:02 UTC
A commit references this bug:

Author: danfe
Date: Wed Jan 24 12:22:59 UTC 2018
New revision: 459838
URL: https://svnweb.freebsd.org/changeset/ports/459838

Log:
  Unbreak the build against Clang 6.0.0 (adheres to C++14 by default).

  PR:	224989

Changes:
  head/graphics/luxrender/files/patch-c++14-fixes
  head/graphics/luxrender14/files/patch-c++14-fixes
Comment 9 Alexey Dokuchaev freebsd_committer 2018-01-24 12:31:25 UTC
I think all ports should be fixed now.  Please close the PR if that is the case, thanks!