Bug 224994 - devel/radare2: clang 6 crashes during build
Summary: devel/radare2: clang 6 crashes during build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dimitry Andric
URL:
Keywords: toolchain
Depends on:
Blocks: 224669
  Show dependency treegraph
 
Reported: 2018-01-08 13:04 UTC by Jan Beich
Modified: 2018-01-15 23:33 UTC (History)
2 users (show)

See Also:


Attachments
libr/util/unum.c (preprocessed, compressed) (94.22 KB, application/x-xz)
2018-01-08 13:04 UTC, Jan Beich
no flags Details
command line args (for clang 6.0) (4.24 KB, text/plain)
2018-01-08 13:04 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-01-08 13:04:12 UTC
Created attachment 189513 [details]
libr/util/unum.c (preprocessed, compressed)

cc -c -O2 -pipe  -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -MD  -isystem /usr/local/include -fPIC -g -Wall -D__UNIX__=1 -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -MD  -isystem /usr/local/include -fPIC -g -Wall -D__UNIX__=1 -DCORELIB -I/wrkdirs/usr/ports/devel/radare2/work/radare2-2.2.0/libr/..//shlr -I/wrkdirs/usr/ports/devel/radare2/work/radare2-2.2.0/libr/../shlr/zip/include -I/wrkdirs/usr/ports/devel/radare2/work/radare2-2.2.0/libr -I/wrkdirs/usr/ports/devel/radare2/work/radare2-2.2.0/libr/include -I../../shlr/sdb/src//src -DHAVE_FORK=1 -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -MD  -isystem /usr/local/include -fPIC -g -Wall -D__UNIX__=1 -DCORELIB -I/wrkdirs/usr/ports/devel/radare2/work/radare2-2.2.0/libr/..//shlr -I/wrkdirs/usr/ports/devel/radare2/work/radare2-2.2.0/libr/../shlr/zip/include -I/wrkdirs/usr/ports/devel/radare2/work/radare2-2.2.0/libr -I/wrkdirs/usr/ports/devel/radare2/work/radare2-2.2.0/libr/include -I../../shlr/sdb/src//src -DHAVE_FORK=1 -o unum.o unum.c
Assertion failed: (ScaledReg == nullptr), function SetCombinedField, file /poudriere/jails/headi386PR224669/usr/src/contrib/llvm/lib/CodeGen/CodeGenPrepare.cpp, line 1963.
cc: error: unable to execute command: Abort trap (core dumped)
cc: error: clang frontend command failed due to signal (use -v to see invocation)
FreeBSD clang version 6.0.0 (branches/release_60 321788) (based on LLVM 6.0.0)
Target: i386-unknown-freebsd12.0
Thread model: posix
InstalledDir: /usr/bin

http://package18.nyi.freebsd.org/data/headi386PR224669-default/2018-01-07_22h53m03s/logs/errors/radare2-2.2.0.log
Comment 1 Jan Beich freebsd_committer 2018-01-08 13:04:46 UTC
Created attachment 189514 [details]
command line args (for clang 6.0)
Comment 2 Dimitry Andric freebsd_committer 2018-01-08 18:12:57 UTC
This is exactly the same crash as bug 224866, reported upstream as https://bugs.llvm.org/show_bug.cgi?id=35805, which turned out to be a duplicate of https://bugs.llvm.org/show_bug.cgi?id=35799.