Bug 225010 - [PATCH] devel/py-zope.configuration: update to 4.1.0
Summary: [PATCH] devel/py-zope.configuration: update to 4.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Ruslan Makhmatkhanov
URL:
Keywords: patch
Depends on:
Blocks: 225543
  Show dependency treegraph
 
Reported: 2018-01-08 18:19 UTC by Charlie Li
Modified: 2018-07-29 11:47 UTC (History)
3 users (show)

See Also:
pi: maintainer-feedback-


Attachments
update to 4.1.0 (1.89 KB, patch)
2018-01-08 18:19 UTC, Charlie Li
no flags Details | Diff
update to 4.1.0 (1.53 KB, patch)
2018-01-30 11:22 UTC, Charlie Li
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie Li 2018-01-08 18:19:29 UTC
Created attachment 189533 [details]
update to 4.1.0

Latest changelog states that python 2.6 and 3.2 support have been dropped, so add minimum python27 requirement. Also add NO_ARCH to silence a sanity check.

A port I'm working on depends on this port, however that port crashes on runtime due to this port's outdated nature, specifically with 3.8.0 not explicitly supporting python 3 for which the other port requires.
Comment 1 Charlie Li 2018-01-29 20:18:31 UTC
See also D14125
Comment 2 Charlie Li 2018-01-30 11:22:55 UTC
Created attachment 190193 [details]
update to 4.1.0

Remove superfluous USES python version.
Comment 3 Charlie Li 2018-07-23 03:31:37 UTC
Comment on attachment 190193 [details]
update to 4.1.0

Patch refreshed based on current ports tree revision, as review D14125.
Comment 4 Kurt Jaeger freebsd_committer 2018-07-29 11:47:02 UTC
Committed, thanks!
Comment 5 commit-hook freebsd_committer 2018-07-29 11:47:24 UTC
A commit references this bug:

Author: pi
Date: Sun Jul 29 11:46:51 UTC 2018
New revision: 475646
URL: https://svnweb.freebsd.org/changeset/ports/475646

Log:
  devel/py-zope.configuration: update 3.8.0 -> 4.1.0

  - Drop support for Python 2.6 and 3.2
  - Add support for Python 3.5 and 3.6

  PR:		225010
  Submitted by:	Charlie Li <ml+freebsd@vishwin.info>
  Approved by:	zope (maintainer timeout)
  Relnotes:	https://pypi.org/project/zope.configuration/

Changes:
  head/devel/py-zope.configuration/Makefile
  head/devel/py-zope.configuration/distinfo