Bug 225040 - devel/py-qt5-core: 'import PyQt5.QtCore' requires sip in the runtime
Summary: devel/py-qt5-core: 'import PyQt5.QtCore' requires sip in the runtime
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-10 08:16 UTC by Yuri Victorovich
Modified: 2019-01-02 16:04 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2018-01-10 08:16:27 UTC
> $ python3.6 test.py
> Traceback (most recent call last):
>   File "sipx.py", line 1, in <module>
>     import PyQt5.QtCore
> ModuleNotFoundError: No module named 'sip'

'sip' should only be required during build.
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-02-14 12:56:53 UTC
pyqt.mk:

_USE_PYQT_ALL=          core dbus dbussupport demo designer designerplugin \
                        gui multimedia network opengl qscintilla2 \
                        sql svg test webkit xml xmlpatterns sip <=
Comment 2 Adriaan de Groot freebsd_committer 2018-05-30 12:45:03 UTC
Confirmed that `import PyQt5.QtCore` (still) fails like this when sip is not installed. I'm not sure, though, that sip is (or should, or could be) optional: it looks like the .so itself tries to load a sip module.
Comment 3 commit-hook freebsd_committer 2019-01-02 16:00:20 UTC
A commit references this bug:

Author: adridg
Date: Wed Jan  2 16:00:00 UTC 2019
New revision: 489087
URL: https://svnweb.freebsd.org/changeset/ports/489087

Log:
  Fix RUN_DEPENDS for devel/py-qt5-core.

  The devel/py-sip port includes the sip module code that is
  needed at runtime ( starting with PyQt 5.11, it seems .. some
  details http://pyqt.sourceforge.net/Docs/PyQt5/installation.html )

  PR:		225040
  Reported by:	yuri

Changes:
  head/devel/py-qt5-core/Makefile
Comment 4 Adriaan de Groot freebsd_committer 2019-01-02 16:04:28 UTC
RUN_DEPENDS fixed.