Bug 225058 - graphics/jogamp-jogl: Update to 2.3.2
Summary: graphics/jogamp-jogl: Update to 2.3.2
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Max Brazhnikov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-10 19:52 UTC by Ruediger Gad
Modified: 2018-01-10 19:53 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (makc)


Attachments
Patch for updating the jogamp-jogl port to 2.3.2 (5.25 KB, patch)
2018-01-10 19:52 UTC, Ruediger Gad
no flags Details | Diff
Modified Start Script for Starting SweetHome3D in FreeBSD with the Updated JOGL Version (993 bytes, application/x-shellscript)
2018-01-10 19:53 UTC, Ruediger Gad
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruediger Gad 2018-01-10 19:52:40 UTC
Created attachment 189597 [details]
Patch for updating the jogamp-jogl port to 2.3.2

Hi,

I wanted to run SweetHome3D (http://www.sweethome3d.com), which requires JOGL 2.3.2.
To get JOGL 2.3.2, I modified jogamp-jogl in the ports tree to update it to this version.

Just bumping the version was not sufficient as some more things had to be
adjusted.
Attached, I send a diff against the original version that shows the
modifications.

With these modifications and a somehwhat adjusted start script for SweetHome3D, I could build and install JOGL 2.3.2 and run SweetHome3D.

Just in case, I also include the modified start script for SweetHome3D.

I hope this is helpful.
If there are any questions or comments, please let me know.



Thank you and best regards,

Ruediger
Comment 1 Ruediger Gad 2018-01-10 19:53:51 UTC
Created attachment 189598 [details]
Modified Start Script for Starting SweetHome3D in FreeBSD with the Updated JOGL Version