Bug 225075 - [UPDATE] news/sabnzbdplus: update to 2.3.2
Summary: [UPDATE] news/sabnzbdplus: update to 2.3.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Florian Smeets
URL:
Keywords:
Depends on: 225074
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-11 16:18 UTC by Ralf van der Enden
Modified: 2018-01-31 18:54 UTC (History)
2 users (show)

See Also:
joshruehlig: maintainer-feedback+


Attachments
Update to 2.3.2 (3.15 KB, patch)
2018-01-11 16:18 UTC, Ralf van der Enden
no flags Details | Diff
Update to 2.3.2 (and add minimum version to py-sabyenc dependency) (3.66 KB, patch)
2018-01-13 22:13 UTC, Ralf van der Enden
no flags Details | Diff
Update to 2.3.2 (and set minimum version for py-sabyenc to 3.3.1) (3.66 KB, patch)
2018-01-15 09:24 UTC, Ralf van der Enden
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf van der Enden 2018-01-11 16:18:41 UTC
Created attachment 189622 [details]
Update to 2.3.2

Changelog: https://github.com/sabnzbd/sabnzbd/releases/tag/2.3.2
Comment 1 joshruehlig 2018-01-11 16:57:16 UTC
Thanks for submitting this. I'll try to test your diff by this weekend.

I am thinking we should also specifically require version 3.3.1 or higher for sabyenc. I believe the below could work.
${PYTHON_PKGNAMEPREFIX}sabyenc>=3.3.1:news/py-sabyenc@${PY_FLAVOR}
Comment 2 Ralf van der Enden 2018-01-13 22:13:34 UTC
Created attachment 189693 [details]
Update to 2.3.2 (and add minimum version to py-sabyenc dependency)
Comment 3 Ralf van der Enden 2018-01-13 22:14:52 UTC
According to the following the minimum version of py-sabyenc is 3.3.2:
sabnzbd/constants.py:SABYENC_VERSION_REQUIRED = '3.3.2'
Comment 4 joshruehlig 2018-01-14 01:22:17 UTC
weird, maybe im reading the changelog wrong.
see the second point here https://github.com/sabnzbd/sabnzbd/releases/tag/2.3.2
Comment 5 joshruehlig 2018-01-14 01:26:41 UTC
i think this commit is relevant.

https://github.com/sabnzbd/sabnzbd/commit/5ca66bfeef33509955ea18569cf8d3113a3fa9f6

i believe sabnzbd only checks for the first two numbers now. 3.3.x
Comment 6 Ralf van der Enden 2018-01-15 09:24:43 UTC
Created attachment 189738 [details]
Update to 2.3.2 (and set minimum version for py-sabyenc to 3.3.1)

You're right. I only looked at the required version, but the final check only looks at the first three position of that version.

Replaced the patch (hopefully for the last time) which sets the mimnimum version to 3.3.1.
Comment 7 Florian Smeets freebsd_committer 2018-01-16 21:26:12 UTC
Hey,

i'm not sure if this is now maintainer approved or not. Should I go ahead and commit it, or wait for a formal approval? 

FWIW, I've been running with this for a few days without problems.

Florian
Comment 8 joshruehlig 2018-01-16 21:33:12 UTC
I haven't had a chance to test it yet. I should have time tonight and I can post back.
Comment 9 joshruehlig 2018-01-17 08:30:03 UTC
Comment on attachment 189738 [details]
Update to 2.3.2 (and set minimum version for py-sabyenc to 3.3.1)

Worked well for me. Thanks!
Comment 10 commit-hook freebsd_committer 2018-01-20 17:38:28 UTC
A commit references this bug:

Author: flo
Date: Sat Jan 20 17:37:33 UTC 2018
New revision: 459531
URL: https://svnweb.freebsd.org/changeset/ports/459531

Log:
  Update to 2.3.2

  PR:		225075
  Submitted by:	Ralf van der Enden <tremere@cainites.net>
  Approved by:	maintainer

Changes:
  head/news/sabnzbdplus/Makefile
  head/news/sabnzbdplus/distinfo
  head/news/sabnzbdplus/pkg-plist
Comment 11 Florian Smeets freebsd_committer 2018-01-31 18:54:05 UTC
Comitted. Thanks