Bug 225206 - devel/xdg-utils: xdg-mime has bogus patch to use stat -f
Summary: devel/xdg-utils: xdg-mime has bogus patch to use stat -f
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-16 03:12 UTC by John Hein
Modified: 2019-01-12 19:58 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
[patch] remove incorrect stat -f patch in favor of [now] fully supported readlink -f (550 bytes, patch)
2018-01-16 03:12 UTC, John Hein
jcfyecrayz: maintainer-approval? (gnome)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2018-01-16 03:12:44 UTC
Created attachment 189782 [details]
[patch] remove incorrect stat -f patch in favor of [now] fully supported readlink -f

'stat -f <file>' has never been correct, but now the patch to use it instead of readlink -f is unnecessary.  readlink -f has worked since freebsd 8, so ust remove the bogus stat -f.

I think 'stat -f' was an attempt to work around the absence of '-f' for readlink in freebsd before 8.x.  But it's just an invalid invocation of stat that basically winds up doing nothing as used in xdg-mime.  It certainly does not follow all links to get the filename of the link target.

One could file a bug with stat where 'stat -L -F %N <file>' reports the name of a link (if <file> is a sym link) instead of the link target.  Maybe that's what was originally intended as a replacement for readlink -f.  But that's a separate bug and such a replacement is no longer needed for xdg-mime.
Comment 1 John Hein 2018-04-18 04:10:11 UTC
Timeout - but needs a committer.
Comment 2 John Hein 2019-01-12 19:56:19 UTC
When the patches from bug 234770 (update to 1.1.3) were committed, they (inadvertenly?) included the patch here, so this bug can be closed (OBE or a duplicate of sorts).
Comment 3 John Hein 2019-01-12 19:58:37 UTC
Call this OBE after r49009 (bug 234770) was committed and included this patch.
https://svnweb.freebsd.org/changeset/ports/490009