Bug 225208 - buildworld fails on my AMD64
Summary: buildworld fails on my AMD64
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-16 05:59 UTC by Neal Delmonico
Modified: 2020-11-15 11:10 UTC (History)
4 users (show)

See Also:


Attachments
the file that stops the compile. Would add the shell file, but can't (155.57 KB, text/x-csrc)
2018-01-16 05:59 UTC, Neal Delmonico
no flags Details
shell file for the file that the compile stopped at (Sema-f016a0.cpp (3.87 KB, application/x-shellscript)
2018-01-18 06:37 UTC, Neal Delmonico
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neal Delmonico 2018-01-16 05:59:29 UTC
Created attachment 189784 [details]
the file that stops the compile. Would add the shell file, but can't

My attempt to build world with Current has failed twice when compiling the AMD64 component b_tgamma.c

I don't a backtrace but I have attached the two files the error message requested.

The Error code for this problem is 254.

I will try again tomorrow after updating my sources.
Comment 1 Conrad Meyer freebsd_committer 2018-01-16 06:06:06 UTC
This file hasn't been significantly changed in >10 years.  What is the error message you are seeing from the build?
Comment 2 Neal Delmonico 2018-01-16 23:12:33 UTC
The error messages were the following:

unable to execute command: Bus error (core dumped)


clang frontend command failed due to the signal (use -v to see invocation)


clang version 6.0.0 based on LLVM 6.0.0



[I am not sure how to use -v in order to see invocation.  I am currently attempting build world again after refreshing my sources for current]
Comment 3 Conrad Meyer freebsd_committer 2018-01-16 23:58:06 UTC
Bus error on AMD64 really surprises me.  The only way I know to get it is accessing past the end of a truncated file via mmap(2).  And b_tgamma.c should not be truncated during the build.

CC'ing dim@, who updated the toolchain to LLVM 6.0.0, in case this is a new regression.
Comment 4 Dimitry Andric freebsd_committer 2018-01-17 07:21:51 UTC
Please also attach the .sh file. You can click "add an attachment" just above the main text field to add as many attachments as needed.

That said, is the error repeatable?  If you build world a few times, does it always crash at exactly the same place?
Comment 5 Neal Delmonico 2018-01-17 16:23:35 UTC
My buildworld yesterday failed also, but this time on a different file.  The file was entries.c  

The error messages were the same.  I will attach the sh file for entries.c  The sh file for b_tgama-98c0a0.c is gone.  I forgot to move it.

The version of clang is release_60 321788

Hope this helps.  

I will try to build world again with refreshed sources today.

Sorry.  The sh file for entries.c is gone.  I guess when I shut down last night it was removed.  My build will certainly fail again today and I will send the relevant files before shutting down.
Comment 6 Neal Delmonico 2018-01-18 06:34:57 UTC
My buildworld failed again at a different place.  There was a different error message:

Assertion failed: ((!Ptr || isHandleInSync()) && "handle not in sync"), function operator =, file /usr/src/contrib/llvm/include/llvm/ADT/DenseMap.h line 1121

error: unable to execute command: Abort trap (core dumped)

error: [same as before]

clang version 5.0.1 (tags/RELEASE_501/final 320880 (based on LLVM 5.0.1)
Comment 7 Neal Delmonico 2018-01-18 06:37:15 UTC
Created attachment 189876 [details]
shell file for the file that the compile stopped at (Sema-f016a0.cpp
Comment 8 Conrad Meyer freebsd_committer 2018-01-18 06:39:08 UTC
Is your hardware failing by any chance?  Have you tried running memtest86+ or other stress testing tools?
Comment 9 Neal Delmonico 2018-01-18 17:11:03 UTC
That is possible.  I have not tried testing this machine.  It has some age on it and I have been having some other problems with this machine.  Anyway, I have another newer machine that I can try the build on.  Will do that today and report the results.  Thanks.
Comment 10 IsabelleGoddard 2020-11-15 11:10:08 UTC
MARKED AS SPAM