Bug 225226 - print/qpdf: Update to 7.1.0
Summary: print/qpdf: Update to 7.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL: http://qpdf.sourceforge.net/files/qpd...
Keywords: patch
: 222056 225606 225608 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-16 16:43 UTC by Dmitri Goutnik
Modified: 2018-02-05 15:48 UTC (History)
8 users (show)

See Also:
yuri: maintainer-feedback+


Attachments
qpdf-7.1.0.patch (7.27 KB, patch)
2018-01-16 16:43 UTC, Dmitri Goutnik
no flags Details | Diff
patch file (7.29 KB, patch)
2018-01-29 13:15 UTC, Dmitri Goutnik
no flags Details | Diff
fix build with prev version installed (1.92 KB, patch)
2018-01-31 13:42 UTC, Dmitri Goutnik
dmgk: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitri Goutnik freebsd_committer 2018-01-16 16:43:31 UTC
Created attachment 189806 [details]
qpdf-7.1.0.patch

* Update to 7.1.0
* Switch to USES=autoreconf,localbase

Changes: http://qpdf.sourceforge.net/files/qpdf-manual.html#ref.release-notes

QA:
  poudriere testport: OK (11a, 10i)
Comment 1 Yuri Victorovich freebsd_committer 2018-01-29 08:34:43 UTC
Patch to Makefile is rejected.
Could you please update it?

Thanks!
Comment 2 Dmitri Goutnik freebsd_committer 2018-01-29 13:15:44 UTC
Created attachment 190157 [details]
patch file

Updated for ports r460298
Comment 3 Yuri Victorovich freebsd_committer 2018-01-29 17:04:38 UTC
https://reviews.freebsd.org/D14119
Comment 4 Yuri Victorovich freebsd_committer 2018-01-29 18:19:55 UTC
*** Bug 222056 has been marked as a duplicate of this bug. ***
Comment 5 Yuri Victorovich freebsd_committer 2018-01-31 04:34:51 UTC
Maintainer timeout expired.
Comment 6 Yuri Victorovich freebsd_committer 2018-01-31 04:39:28 UTC
Committed.
Thank you for the patch!
Comment 7 commit-hook freebsd_committer 2018-01-31 04:39:30 UTC
A commit references this bug:

Author: yuri
Date: Wed Jan 31 04:39:24 UTC 2018
New revision: 460458
URL: https://svnweb.freebsd.org/changeset/ports/460458

Log:
  print/qpdf: Update to 7.1.0

  Additional changes:
  * Added a patch to work around the missing include:
    https://github.com/qpdf/qpdf/pull/172
  * Added a patch to fix the clang and gcc build problem:
    https://github.com/qpdf/qpdf/issues/177

  PR:		225226
  Reported by:	Dmitri Goutnik <dg@syrec.org>
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D14119

Changes:
  head/print/qpdf/Makefile
  head/print/qpdf/distinfo
  head/print/qpdf/files/patch-libqpdf_Pl__PNGFilter.cc
  head/print/qpdf/files/patch-libqpdf_QUtil.cc
  head/print/qpdf/files/patch-libtests-build.mk
  head/print/qpdf/files/patch-make-libtool.mk
  head/print/qpdf/files/patch-make_libtool.mk
  head/print/qpdf/pkg-plist
Comment 8 VVD 2018-01-31 12:09:22 UTC
Port can't be build if installed previous version.

Look at this: -L/usr/local/lib -lqpdf -Llibqpdf/build
Must be: -lqpdf -Llibqpdf/build -L/usr/local/lib
Local libs MUST have higher priority.
Why nobody didn't test port before commit on _real_ system?!

libtool: link: c++ -O2 -pipe -march=prescott -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -Wold-style-cast -Wall libtests/build/buffer.o -o libtests/build/buffer -fstack-protector  -ljpeg -lz -L/usr/local/lib -lqpdf -Llibqpdf/build
libtests/build/bits.o: In function `main':
libtests/bits.cc:(.text+0x62b): undefined reference to `BitStream::getBitsSigned(int)'
libtests/bits.cc:(.text+0x6a7): undefined reference to `BitStream::getBitsSigned(int)'
libtests/bits.cc:(.text+0x723): undefined reference to `BitStream::getBitsSigned(int)'
libtests/bits.cc:(.text+0x79f): undefined reference to `BitStream::getBitsSigned(int)'
libtests/bits.cc:(.text+0x81b): undefined reference to `BitStream::getBitsSigned(int)'
libtests/bits.cc:(.text+0xab4): undefined reference to `BitWriter::writeBitsSigned(long long, unsigned int)'
libtests/bits.cc:(.text+0xac3): undefined reference to `BitWriter::writeBitsSigned(long long, unsigned int)'
libtests/bits.cc:(.text+0xad2): undefined reference to `BitWriter::writeBitsSigned(long long, unsigned int)'
libtests/bits.cc:(.text+0xae1): undefined reference to `BitWriter::writeBitsSigned(long long, unsigned int)'
libtests/bits.cc:(.text+0xaf0): undefined reference to `BitWriter::writeBitsSigned(long long, unsigned int)'
c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[2]: *** [libtests/build.mk:44: libtests/build/bits] Error 1
gmake[2]: *** Waiting for unfinished jobs....
libtool: link: c++ -O2 -pipe -march=prescott -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -Wold-style-cast -Wall libtests/build/concatenate.o -o libtests/build/concatenate -fstack-protector  -ljpeg -lz -L/usr/local/lib -lqpdf -Llibqpdf/build
gmake[2]: Leaving directory '/usr/obj/usr/ports/print/qpdf/work/qpdf-7.1.0'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/print/qpdf
*** Error code 1

Stop.
make: stopped in /usr/ports/print/qpdf
Comment 9 Dmitri Goutnik freebsd_committer 2018-01-31 13:42:09 UTC
Created attachment 190221 [details]
fix build with prev version installed
Comment 10 Yuri Victorovich freebsd_committer 2018-01-31 16:11:21 UTC
Re-opened.

Thank you for your patch.
Comment 11 Walter Schwarzenfeld freebsd_triage 2018-02-01 16:26:37 UTC
*** Bug 225606 has been marked as a duplicate of this bug. ***
Comment 12 O. Hartmann 2018-02-01 18:20:29 UTC
See Bug  225608 . Update to 7.1.0 results in linker error on CURRENT and so ports requiring print/qpdf depending on options, like print/hplip, fails to build/install.
Comment 13 Yuri Victorovich freebsd_committer 2018-02-01 18:49:40 UTC
*** Bug 225608 has been marked as a duplicate of this bug. ***
Comment 14 Yuri Victorovich freebsd_committer 2018-02-01 18:51:24 UTC
The upstream is expected to accept this in the release: https://github.com/qpdf/qpdf/issues/176
Comment 15 Yuri Victorovich freebsd_committer 2018-02-05 03:24:48 UTC
Committed the 7.1.1 update that fixed these problems:
* build breaks when previous version is installed: https://github.com/qpdf/qpdf/issues/176
* error: reinterpret_cast from 'nullptr_t' to 'char *': https://github.com/qpdf/qpdf/issues/177
Comment 16 commit-hook freebsd_committer 2018-02-05 03:25:24 UTC
A commit references this bug:

Author: yuri
Date: Mon Feb  5 03:24:42 UTC 2018
New revision: 460959
URL: https://svnweb.freebsd.org/changeset/ports/460959

Log:
  print/qpdf: Update to 7.1.1 (a followup release)

  Fixed bugs that were left by the first commit for bug#225226
  that updated qpdf to 7.1.0:
  * build breaks when previous version is installed:
    https://github.com/qpdf/qpdf/issues/176
  * error: reinterpret_cast from 'nullptr_t' to 'char *':
    https://github.com/qpdf/qpdf/issues/177

  PR:		225226
  Reported by:	several users
  Approved by:	adamw (mentor)
  Differential Revision:	https://reviews.freebsd.org/D14201

Changes:
  head/print/qpdf/Makefile
  head/print/qpdf/distinfo
  head/print/qpdf/files/patch-libqpdf_Pl__PNGFilter.cc
  head/print/qpdf/files/patch-libqpdf_QUtil.cc
  head/print/qpdf/pkg-plist
Comment 17 VVD 2018-02-05 15:48:09 UTC
Thanks!