Bug 225266 - finance/kmymoney-kde4: clang 6 crashes during build
Summary: finance/kmymoney-kde4: clang 6 crashes during build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Jason E. Hale
URL:
Keywords: needs-qa, toolchain
Depends on:
Blocks: 224669
  Show dependency treegraph
 
Reported: 2018-01-17 16:46 UTC by Jan Beich
Modified: 2018-05-21 12:25 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (jhale)
jbeich: maintainer-feedback? (dim)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-01-17 16:46:47 UTC
/usr/bin/c++  -DHAVE_CONFIG_H -DKDE4_CMAKE_TOPLEVEL_DIR_LENGTH=45 -DKDE_DEPRECATED_WARNINGS -DQT_NO_CAST_TO_ASCII -DQT_NO_STL -DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS -D_REENTRANT -Ikmymoney -Ikmymoney/kmm_config_autogen/include -I. -Ikmymoney/dialogs -Ikmymoney/widgets -Ikmymoney/mymoney -Ikmymoney/mymoney/storage -Ikmymoney/plugins -Ikmymoney/views -Ikmymoney/converter -Ikmymoney/dialogs/settings -Ikmymoney/reports -Ikmymoney/wizards/endingbalancedlg -Ikmymoney/wizards/newinvestmentwizard -Ikmymoney/wizards/newloanwizard -Ikmymoney/wizards/wizardpages -Ikmymoney/models -Ikmymoney/payeeidentifier/ibanandbic/widgets -Ikmymoney/payeeidentifier/ibanandbic -Ikmymoney/payeeidentifier/nationalaccount -Ilibkgpgfile -Ilibkdchart/include -I/usr/local/include/kde4 -I/usr/local/include/kde4/KDE -I/usr/local/include/KDE -I/usr/local/include -I/usr/local/include/qt4/phonon -I/usr/local/include/qt4/QtXmlPatterns -I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4/QtWebKit -I/usr/local/include/qt4/QtTest -I/usr/local/include/qt4/QtSvg -I/usr/local/include/qt4/QtSql -I/usr/local/include/qt4/QtScript -I/usr/local/include/qt4/QtOpenGL -I/usr/local/include/qt4/QtNetwork -I/usr/local/include/qt4/QtDeclarative -I/usr/local/include/qt4/QtDBus -I/usr/local/include/qt4/Qt3Support -I/usr/local/include/qt4/QtGui -I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/Qt -I/usr/local/share/qt4/mkspecs/default -I/usr/local/include/qt4 -O2 -pipe -fstack-protector -fno-strict-aliasing -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -Woverloaded-virtual -fno-common -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -Wno-return-type-c-linkage -fexceptions -UQT_NO_EXCEPTIONS -fexceptions -UQT_NO_EXCEPTIONS -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG    -D_LARGEFILE64_SOURCE  -D_LARGEFILE64_SOURCE -MD -MT kmymoney/CMakeFiles/kmm_config.dir/kmymoneysettings.cpp.o -MF kmymoney/CMakeFiles/kmm_config.dir/kmymoneysettings.cpp.o.d -o kmymoney/CMakeFiles/kmm_config.dir/kmymoneysettings.cpp.o -c kmymoney/kmymoneysettings.cpp
Assertion failed: ((!RequiresNullTerminator || BufEnd[0] == 0) && "Buffer is not null terminated!"), function init, file /usr/local/poudriere/jails/head-amd64/usr/src/contrib/llvm/lib/Support/MemoryBuffer.cpp, line 48.
c++: error: unable to execute command: Abort trap (core dumped)
c++: error: clang frontend command failed due to signal (use -v to see invocation)
FreeBSD clang version 6.0.0 (branches/release_60 321788) (based on LLVM 6.0.0)
Target: x86_64-unknown-freebsd12.0
Thread model: posix
InstalledDir: /usr/bin

http://beefy12.nyi.freebsd.org/data/head-amd64-default/p459147_s328035/logs/errors/kmymoney-4.8.0_10.log
Comment 1 Jan Beich freebsd_committer 2018-01-17 17:20:17 UTC
This looks like an intermittent crash. Only happens on amd64 during "stage" phase of the build. Simply restarting the build is enough to work around.o
Comment 2 Jason E. Hale freebsd_committer 2018-01-21 13:29:16 UTC
I have been receiving build failure reports for this port on CURRENT since September 20, but I have only very recently (yesterday) been able to get a CURRENT machine up and running to investigate.

I can't reproduce the error right now. I tried building it with 1200055-amd64 and clang 6 on my new box and it was fine.

I don't think it is necessarily related to clang 6 or amd64, because I have received failure logs for 12-CURRENT-[i386|amd64] with clang 5 and more recently for 10.3-amd64. It must be happening randomly because I see that there are recent packages available on pkg.FreeBSD.org for [10|11|12]-[i386|amd64].
Comment 3 Jason E. Hale freebsd_committer 2018-03-09 07:14:42 UTC
I still haven’t been able to reproduce this locally, but I got a different failure log that leads me to believe there is a race condition happening. kmymoneysettings.cpp is a generated file and from the build log below, it looks like it is being compiled before it is fully generated. I’ll try marking the port MAKE_JOBS_UNSAFE and see if that resolves the issue on the build cluster.

/usr/bin/c++  -DHAVE_CONFIG_H -DKDE4_CMAKE_TOPLEVEL_DIR_LENGTH=45 -DKDE_DEPRECATED_WARNINGS -DQT_NO_CAST_TO_ASCII -DQT_NO_STL -DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS -D_REENTRANT -Ikmymoney -Ikmymoney/kmm_config_autogen/include -I. -Ikmymoney/dialogs -Ikmymoney/widgets -Ikmymoney/mymoney -Ikmymoney/mymoney/storage -Ikmymoney/plugins -Ikmymoney/views -Ikmymoney/converter -Ikmymoney/dialogs/settings -Ikmymoney/reports -Ikmymoney/wizards/endingbalancedlg -Ikmymoney/wizards/newinvestmentwizard -Ikmymoney/wizards/newloanwizard -Ikmymoney/wizards/wizardpages -Ikmymoney/models -Ikmymoney/payeeidentifier/ibanandbic/widgets -Ikmymoney/payeeidentifier/ibanandbic -Ikmymoney/payeeidentifier/nationalaccount -Ilibkgpgfile -Ilibkdchart/include -I/usr/local/include/kde4 -I/usr/local/include/kde4/KDE -I/usr/local/include/KDE -I/usr/local/include -I/usr/local/include/qt4/phonon -I/usr/local/include/qt4/QtXmlPatterns -I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4/QtWebKit -I/usr/local/include/qt4/QtTest -I/usr/local/include/qt4/QtSvg -I/usr/local/include/qt4/QtSql -I/usr/local/include/qt4/QtScript -I/usr/local/include/qt4/QtOpenGL -I/usr/local/include/qt4/QtNetwork -I/usr/local/include/qt4/QtDeclarative -I/usr/local/include/qt4/QtDBus -I/usr/local/include/qt4/Qt3Support -I/usr/local/include/qt4/QtGui -I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/Qt -I/usr/local/share/qt4/mkspecs/default -I/usr/local/include/qt4 -O2 -pipe -fstack-protector -fno-strict-aliasing -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -Woverloaded-virtual -fno-common -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -Wno-return-type-c-linkage -fexceptions -UQT_NO_EXCEPTIONS -fexceptions -UQT_NO_EXCEPTIONS -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG    -D_LARGEFILE64_SOURCE  -D_LARGEFILE64_SOURCE -MD -MT kmymoney/CMakeFiles/kmm_config.dir/kmymoneysettings.cpp.o -MF kmymoney/CMakeFiles/kmm_config.dir/kmymoneysettings.cpp.o.d -o kmymoney/CMakeFiles/kmm_config.dir/kmymoneysettings.cpp.o -c kmymoney/kmymoneysettings.cpp
kmymoney/kmymoneysettings.cpp:67:70: error: expected '}'
  addItem( itemAutoSaveOnClose, QLatin1String( "AutoSaveOnClose" ) );
                                                                     ^
kmymoney/kmymoneysettings.cpp:29:1: note: to match this '{'
{
^
1 error generated.

http://beefy12.nyi.freebsd.org/data/head-amd64-default/p463680_s330525/logs/kmymoney-4.8.0_12.log
Comment 4 commit-hook freebsd_committer 2018-03-09 07:21:54 UTC
A commit references this bug:

Author: jhale
Date: Fri Mar  9 07:21:44 UTC 2018
New revision: 463935
URL: https://svnweb.freebsd.org/changeset/ports/463935

Log:
  Mark MAKE_JOBS_UNSAFE to try to resolve intermittent build failures on the
  package build cluster. It appears that kmymoneysetting.cpp is being
  compiled before it is fully generated.

  PR:		225266
  Submitted by:	jbeich
  Reported by:	pkg-fallout

Changes:
  head/finance/kmymoney-kde4/Makefile
Comment 5 Dimitry Andric freebsd_committer 2018-05-20 23:15:05 UTC
Shall we close this now?