Bug 225280 - www/palemoon: clang crashes during build
Summary: www/palemoon: clang crashes during build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords: toolchain
Depends on:
Blocks:
 
Reported: 2018-01-17 20:15 UTC by Jan Beich
Modified: 2018-02-06 23:50 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (lichray)


Attachments
js/src/asmjs/AsmJSModule.cpp (compressed, preprocessed) (825.12 KB, application/x-xz)
2018-01-17 20:15 UTC, Jan Beich
no flags Details
command line args (for clang 6.0) (5.02 KB, text/plain)
2018-01-17 20:16 UTC, Jan Beich
no flags Details
proposed patch (941 bytes, patch)
2018-01-17 21:02 UTC, lichray
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-01-17 20:15:32 UTC
Created attachment 189861 [details]
js/src/asmjs/AsmJSModule.cpp (compressed, preprocessed)

/usr/bin/c++ -o Unified_cpp_js_src0.o -c  -I../../dist/system_wrappers -include /wrkdirs/usr/ports/www/palemoon/work/Pale-Moon-27.6.2_Release/config/gcc_hidden.h -DEXPORT_JS_API -DJS_HAS_CTYPES -DDLL_PREFIX='"lib"' -DDLL_SUFFIX='".so"' -DMOZ_GLUE_IN_PROGRAM -DAB_CD= -DNO_NSPR_10_SUPPORT -I/wrkdirs/usr/ports/www/palemoon/work/Pale-Moon-27.6.2_Release/js/src -I. -I/usr/local/lib/libffi-3.2.1/include -I/usr/local/include -I../../dist/include   -I/usr/local/include/nspr         -fPIC  -Qunused-arguments -DLIBICONV_PLUG -isystem /usr/local/include  -DMOZILLA_CLIENT -include ../../js/src/js-confdefs.h -MD -MP -MF .deps/Unified_cpp_js_src0.o.pp -Qunused-arguments -DLIBICONV_PLUG -isystem /usr/local/include  -Qunused-arguments -Wall -Wsign-compare -Wtype-limits -Wno-invalid-offsetof -Wno-c++0x-extensions -Wno-unknown-warning-option -Wno-return-type-c-linkage -O2 -pipe -O3 -DLIBICONV_PLUG -isystem /usr/local/include -fno-strict-aliasing -DLIBICONV_PLUG -isystem /usr/local/include -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pipe  -DNDEBUG -DTRIMMED -O2 -O3       /wrkdirs/usr/ports/www/palemoon/work/Pale-Moon-/obj-armv6-unknown-freebsd12.0/js/src/Unified_cpp_js_src0.cpp
[...]
Assertion failed: ((PartVT.isInteger() || PartVT == MVT::x86mmx) && ValueVT.isInteger() && "Unknown mismatch!"), function getCopyToParts, file /usr/local/poudriere/jails/head-armv6/usr/src/contrib/llvm/lib/CodeGen/SelectionDAG/SelectionDAGBuilder.cpp, line 533.
c++: error: unable to execute command: Abort trap (core dumped)
c++: error: clang frontend command failed due to signal (use -v to see invocation)
FreeBSD clang version 6.0.0 (branches/release_60 321788) (based on LLVM 6.0.0)
Target: armv6-unknown-freebsd12.0-gnueabihf
Thread model: posix
InstalledDir: /nxb-bin/usr/bin

http://beefy8.nyi.freebsd.org/data/head-armv6-default/p459021_s327977/logs/errors/palemoon-27.6.2_1.log (clang 6)
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p458501_s327711/logs/palemoon-27.6.2_1.log (clang 5)
Comment 1 Jan Beich freebsd_committer 2018-01-17 20:16:14 UTC
Created attachment 189862 [details]
command line args (for clang 6.0)
Comment 2 Jan Beich freebsd_committer 2018-01-17 20:25:39 UTC
Can probably be fixed by applying www/libxul/files/patch-bug1278861
Comment 3 Dimitry Andric freebsd_committer 2018-01-17 20:59:44 UTC
(In reply to Jan Beich from comment #2)
> Can probably be fixed by applying www/libxul/files/patch-bug1278861

Yes, this looks very much like a duplicate of bug 199450, bug 202229, https://bugs.llvm.org/show_bug.cgi?id=23229, and https://bugs.llvm.org/show_bug.cgi?id=23244, which are unfortunately still not solved upstream, and no movement was detected. :-/
Comment 4 lichray 2018-01-17 21:02:40 UTC
Created attachment 189865 [details]
proposed patch
Comment 5 commit-hook freebsd_committer 2018-02-03 10:37:08 UTC
A commit references this bug:

Author: tobik
Date: Sat Feb  3 10:36:47 UTC 2018
New revision: 460803
URL: https://svnweb.freebsd.org/changeset/ports/460803

Log:
  www/palemoon: Update to 27.7.2

  - Attempt to fix build with Clang 6 [1]

  Changes:	http://www.palemoon.org/releasenotes.shtml
  PR:		225644, 225280 [1]
  Approved by:	lichray@gmail.com (maintainer)
  Security:	5044bd23-08cb-11e8-b08f-00012e582166

Changes:
  head/www/palemoon/Makefile
  head/www/palemoon/distinfo
  head/www/palemoon/files/patch-bug1278861
Comment 6 commit-hook freebsd_committer 2018-02-03 12:42:57 UTC
A commit references this bug:

Author: tobik
Date: Sat Feb  3 12:42:15 UTC 2018
New revision: 460808
URL: https://svnweb.freebsd.org/changeset/ports/460808

Log:
  MFH: r460803

  www/palemoon: Update to 27.7.2

  - Attempt to fix build with Clang 6 [1]

  Changes:	http://www.palemoon.org/releasenotes.shtml
  PR:		225644, 225280 [1]
  Approved by:	lichray@gmail.com (maintainer)
  Security:	5044bd23-08cb-11e8-b08f-00012e582166

  Approved by:	ports-secteam blanket

Changes:
_U  branches/2018Q1/
  branches/2018Q1/www/palemoon/Makefile
  branches/2018Q1/www/palemoon/distinfo
  branches/2018Q1/www/palemoon/files/patch-bug1278861