Bug 225307 - [PATCH] textproc/opensp: fix build with clang 6
Summary: [PATCH] textproc/opensp: fix build with clang 6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Guido Falsi
URL:
Keywords: patch
: 225371 (view as bug list)
Depends on:
Blocks: 224669
  Show dependency treegraph
 
Reported: 2018-01-18 22:26 UTC by Guido Falsi
Modified: 2018-02-03 13:38 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kuriyama)


Attachments
clang 6 patch (13.34 KB, patch)
2018-01-18 22:26 UTC, Guido Falsi
madpilot: maintainer-approval? (kuriyama)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2018-01-18 22:26:51 UTC
Created attachment 189895 [details]
clang 6 patch

Hi,

I have created a patch to allow opensp to be compiled correctly on recent head with clang 6.

The configure script has an old stanza which is not needed with modern compilers, I removed.

I also had to add some using clauses to allow it to compile.

While at it I also converted the port to USES=localbase.


Can you review and, if you see fit, approve this patch?

Thanks.
Comment 1 Antoine Brodin freebsd_committer 2018-01-25 06:09:42 UTC
*** Bug 225371 has been marked as a duplicate of this bug. ***
Comment 2 Antoine Brodin freebsd_committer 2018-02-03 12:58:00 UTC
Maintainer timed out.
Comment 3 commit-hook freebsd_committer 2018-02-03 13:37:46 UTC
A commit references this bug:

Author: madpilot
Date: Sat Feb  3 13:36:45 UTC 2018
New revision: 460812
URL: https://svnweb.freebsd.org/changeset/ports/460812

Log:
  - Fix opensp build with clang 6
  - While here convert to USES=localbase

  PR:		225307
  Submitted by:	me
  Approved by:	Maintainer timeout

Changes:
  head/textproc/opensp/Makefile
  head/textproc/opensp/files/patch-configure
  head/textproc/opensp/files/patch-include_IList.h
  head/textproc/opensp/files/patch-include_IListIter.h
  head/textproc/opensp/files/patch-include_Ptr.h
  head/textproc/opensp/files/patch-lib_Parser.h
Comment 4 Guido Falsi freebsd_committer 2018-02-03 13:38:09 UTC
Committed.