Bug 225332 - net/qt5-network: Fix SSL runtime detection code with LibreSSL
Summary: net/qt5-network: Fix SSL runtime detection code with LibreSSL
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ben Woods
URL:
Keywords: patch, patch-ready
: 224982 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-20 01:38 UTC by Ben Woods
Modified: 2018-01-21 08:55 UTC (History)
5 users (show)

See Also:
tcberner: maintainer-feedback+
woodsb02: merge-quarterly-


Attachments
Patch to fix net/qt5-network SSL runtime detection code with LibreSSL (4.51 KB, patch)
2018-01-20 01:38 UTC, Ben Woods
woodsb02: maintainer-approval? (kde)
tcberner: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Woods freebsd_committer 2018-01-20 01:38:47 UTC
Created attachment 189924 [details]
Patch to fix net/qt5-network SSL runtime detection code with LibreSSL

net/qt5-network: Fix SSL runtime detection code with LibreSSL

Patch taken from OpenBSD ports:
  http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/x11/qt5/qtbase/patches/patch-src_network_ssl_qsslsocket_openssl_symbols_cpp.diff?r1=1.2&r2=1.3
  http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/x11/qt5/qtbase/patches/patch-src_network_ssl_qsslsocket_openssl_symbols_p_h.diff?r1=1.2&r2=1.3

Original report from Brendan Doyle <doyle.brendan@yandex.com>.
Comment 1 Ben Woods freebsd_committer 2018-01-20 01:40:56 UTC
Without this fix, I am seeing the following error in Quassel built with LibreSSL:

$ quasselclient
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
QSslSocket: cannot resolve BN_is_word
Incompatible version of OpenSSL
Enabling compression...
Using the DataStream protocol...
Starting encryption...


In the GUI interface I see the error:
Invalid or empty cipher list (error:14FFF0B9:lib(20):func(4095):reason(185))
Comment 2 Ben Woods freebsd_committer 2018-01-20 01:41:35 UTC
Comment on attachment 189924 [details]
Patch to fix net/qt5-network SSL runtime detection code with LibreSSL

Waiting for approval from kde ports team to commit patch.
Comment 3 Ben Woods freebsd_committer 2018-01-20 02:14:44 UTC
I am yet to confirm this patch fully fixes the issue - builds in progress for testing.
Comment 4 Ben Woods freebsd_committer 2018-01-20 09:50:54 UTC
Confirmed - this patch fixes the qt5-network SSL runtime detection code with LibreSSL for me, and quassel is now working with it.
Comment 5 Tobias C. Berner freebsd_committer 2018-01-20 10:09:01 UTC
Hi Ben

Looks sane, please go ahead.


mfg Tobias
Comment 6 Ben Woods freebsd_committer 2018-01-20 11:56:34 UTC
Committed. Thanks!
Comment 7 commit-hook freebsd_committer 2018-01-20 11:56:53 UTC
A commit references this bug:

Author: woodsb02
Date: Sat Jan 20 11:56:15 UTC 2018
New revision: 459510
URL: https://svnweb.freebsd.org/changeset/ports/459510

Log:
  net/qt5-network: Fix SSL runtime detection code with LibreSSL

  Patch taken from OpenBSD ports:
    http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/x11/qt5/qtbase/patches/patch-src_network_ssl_qsslsocket_openssl_symbols_cpp.diff?r1=1.2&r2=1.3
    http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/x11/qt5/qtbase/patches/patch-src_network_ssl_qsslsocket_openssl_symbols_p_h.diff?r1=1.2&r2=1.3

  PR:		225332
  Approved by:	tcberner
  Obtained from:	OpenBSD ports

Changes:
  head/net/qt5-network/Makefile
  head/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols.cpp
  head/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h
Comment 8 Ben Woods freebsd_committer 2018-01-20 11:57:36 UTC
No need to merge to 2018Q1, as QT5 has not been upgraded to 5.9.3 in quarterly.
Comment 9 Ben Woods freebsd_committer 2018-01-21 08:55:41 UTC
*** Bug 224982 has been marked as a duplicate of this bug. ***